summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordr460nf1r32022-06-01 22:15:10 +0200
committerdr460nf1r32022-06-01 22:15:10 +0200
commitb0f3e16228f9f42b6ae44a33ff0fa05a556d5745 (patch)
tree2a9437905738add33c0bd5a1c6f10eeb8c0901cb
parent81f880d6e0f2d5174a3236d1accc114da7bc4b51 (diff)
downloadaur-b0f3e16228f9f42b6ae44a33ff0fa05a556d5745.tar.gz
Update
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 28 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5412fefeadc..ad14614b1570 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firedragon
pkgdesc = Librewolf fork build using custom branding, settings & KDE patches by OpenSUSE
- pkgver = 100.0.2
- pkgrel = 4
+ pkgver = 101.0
+ pkgrel = 1
url = https://gitlab.com/dr460nf1r3/settings/
install = firedragon.install
arch = x86_64
@@ -63,22 +63,24 @@ pkgbase = firedragon
options = !strip
options = !lto
options = !debug
- backup = usr/lib/librewolf/librewolf.cfg
- backup = usr/lib/librewolf/distribution/policies.json
- source = https://archive.mozilla.org/pub/firefox/releases/100.0.2/source/firefox-100.0.2.source.tar.xz
- source = https://archive.mozilla.org/pub/firefox/releases/100.0.2/source/firefox-100.0.2.source.tar.xz.asc
+ backup = usr/lib/firedragon/firedragon.cfg
+ backup = usr/lib/firedragon/distribution/policies.json
+ source = https://archive.mozilla.org/pub/firefox/releases/101.0/source/firefox-101.0.source.tar.xz
+ source = https://archive.mozilla.org/pub/firefox/releases/101.0/source/firefox-101.0.source.tar.xz.asc
source = firedragon.desktop
source = git+https://gitlab.com/dr460nf1r3/common.git
source = git+https://gitlab.com/dr460nf1r3/settings.git
source = librewolf-source::git+https://gitlab.com/librewolf-community/browser/source.git
source = librewolf-settings::git+https://gitlab.com/librewolf-community/settings.git
+ source = cachyos-source::git+https://github.com/CachyOS/CachyOS-Browser-Common.git
validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
- sha256sums = dc109861204f6938fd8f147af89a694eb516f3d4bb64ce3f0116452d654a8417
+ sha256sums = 55ab5b517d58bbcbc837640263a8371cf1fba3d9f508e54537c4d2cbbfb86095
sha256sums = SKIP
sha256sums = 158152bdb9ef6a83bad62ae03a3d9bc8ae693b34926e53cc8c4de07df20ab22d
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = firedragon
diff --git a/.gitignore b/.gitignore
index 415b85339586..c90e38626aaa 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,7 @@ common/
pkg/
settings/
src/
-*.tar.xz
+cachyos-source
+librewolf-settings
+librewolf-source
+*.tar.xz*
diff --git a/PKGBUILD b/PKGBUILD
index e12d456beea7..e8e5960440a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=firedragon
_pkgname=FireDragon
-pkgver=100.0.2
-pkgrel=5
+pkgver=101.0
+pkgrel=1
pkgdesc="Librewolf fork build using custom branding, settings & KDE patches by OpenSUSE"
arch=(x86_64 x86_64_v3 aarch64)
backup=('usr/lib/firedragon/firedragon.cfg'
@@ -36,14 +36,16 @@ source=(https://archive.mozilla.org/pub/firefox/releases/"$pkgver"/source/firefo
"git+https://gitlab.com/dr460nf1r3/common.git"
"git+https://gitlab.com/dr460nf1r3/settings.git"
"librewolf-source::git+https://gitlab.com/librewolf-community/browser/source.git"
- "librewolf-settings::git+https://gitlab.com/librewolf-community/settings.git")
+ "librewolf-settings::git+https://gitlab.com/librewolf-community/settings.git"
+ "cachyos-source::git+https://github.com/CachyOS/CachyOS-Browser-Common.git")
# source_aarch64=()
-sha256sums=('dc109861204f6938fd8f147af89a694eb516f3d4bb64ce3f0116452d654a8417'
+sha256sums=('55ab5b517d58bbcbc837640263a8371cf1fba3d9f508e54537c4d2cbbfb86095'
'SKIP'
'158152bdb9ef6a83bad62ae03a3d9bc8ae693b34926e53cc8c4de07df20ab22d'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
# sha256sums_aarch64=()
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@@ -61,6 +63,9 @@ prepare() {
local _librewolf_patches_dir
_librewolf_patches_dir="${srcdir}/librewolf-source/patches"
+ local _cachyos_patches_dir
+ _cachyos_patches_dir="${srcdir}/cachyos-source/patches"
+
sed -i 's/lib\/librewolf/lib\/firedragon/g' "${_librewolf_patches_dir}/mozilla_dirs.patch"
sed -i 's/lib64\/librewolf/lib64\/firedragon/g' "${_librewolf_patches_dir}/mozilla_dirs.patch"
sed -i 's/librewolf/firedragon/g' "${_librewolf_patches_dir}/mozilla_dirs.patch"
@@ -70,6 +75,9 @@ prepare() {
popd
pushd "${_librewolf_patches_dir}" && sh "${srcdir}/common/rebrand.sh"
popd
+ pushd "${_cachyos_patches_dir}" && sh "${srcdir}/common/rebrand.sh"
+ popd
+
cat >../mozconfig <<END
ac_add_options --enable-application=browser
@@ -174,12 +182,11 @@ fi
# Debian patch to enable global menubar
# disabled for the default build, as it seems to cause issues in some configurations
# 2022-01-21: re-enabled because it seems to not mess things up anymore nowadays?
- patch -Np1 -i "${_librewolf_patches_dir}"/unity-menubar.patch
+ # patch -Np1 -i "${_librewolf_patches_dir}"/unity-menubar.patch
# KDE menu
- # patch -Np1 -i "${_librewolf_patches_dir}"/mozilla-kde.patch
- # custom patch that does not conflict with the unity patch
- patch -Np1 -i "${_librewolf_patches_dir}"/mozilla-kde_after_unity.patch
+ patch -Np1 -i "${_cachyos_patches_dir}"/kde/0001-kde-unity.patch
+ patch -Np1 -i "${_cachyos_patches_dir}"/kde/mozilla-nongnome-proxies.patch
# Disabling Pocket
patch -Np1 -i "${_librewolf_patches_dir}"/sed-patches/disable-pocket.patch