summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-22 11:06:38 +0800
committerzxp198210052024-03-22 11:06:38 +0800
commite6bd93b03016116e7e6f7ec9a46dad0c4ba7f4cf (patch)
tree3d110946cd91ed63054f9bea28e6ff7c331d4e8c
parent91c4013336c02312e7ca32d84d27a26d3350aa70 (diff)
downloadaur-e6bd93b03016116e7e6f7ec9a46dad0c4ba7f4cf.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--firefly-iota-desktop.sh5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78ba6394310e..2f9801da7d4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefly-iota-desktop-bin
pkgdesc = Manage your IOTA assets directly from your computer with both software and hardware wallet support. Earn staking rewards and participate in governance votes.
pkgver = 2.0.9
- pkgrel = 1
+ pkgrel = 2
url = https://firefly.iota.org/
arch = x86_64
license = Apache-2.0
@@ -13,6 +13,6 @@ pkgbase = firefly-iota-desktop-bin
source = firefly-iota-desktop-2.0.9.AppImage::https://github.com/iotaledger/firefly/releases/download/desktop-iota-2.0.9/firefly-iota-desktop-2.0.9.AppImage
source = firefly-iota-desktop.sh
sha256sums = 1fecfb2a80d416b33e8862d92e1e7c5c2f1f2ca86caf766e92e6f1cc543b334a
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = firefly-iota-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 16d30fbe1fb1..3c136dabcaa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=firefly-iota-desktop-bin
pkgver=2.0.9
_electronversion=27
-pkgrel=1
+pkgrel=2
pkgdesc="Manage your IOTA assets directly from your computer with both software and hardware wallet support. Earn staking rewards and participate in governance votes."
arch=('x86_64')
url="https://firefly.iota.org/"
@@ -24,11 +24,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('1fecfb2a80d416b33e8862d92e1e7c5c2f1f2ca86caf766e92e6f1cc543b334a'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/firefly-iota-desktop.sh b/firefly-iota-desktop.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/firefly-iota-desktop.sh
+++ b/firefly-iota-desktop.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file