summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Saparelli2017-07-19 22:16:47 +1200
committerFélix Saparelli2017-07-19 22:50:53 +1200
commitcd3114cefdf4a85303be6877e00f47abc1d12302 (patch)
tree980f9c65b6556e7454c46cc9dc3ab42c9329e98c
parentf2dad33047e054ad90bc2c4001d7e56ccafadc4c (diff)
downloadaur-cd3114cefdf4a85303be6877e00f47abc1d12302.tar.gz
Adjust for pacaur
Turns out that Pacaur does more than one pass through the PKGBUILD, so the timestamp used to avoid pacaur's overzealous build caching is not matching on the later run! Thus instead we pre-emptively fetch the txt file that contains the nightly *build* date, and use that to identify the downloaded file.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD23
2 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0fa8e4f47e8..a2b5b13eff57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = firefox-always-nightly
pkgname = firefox-always-nightly
pkgdesc = Standalone web browser from mozilla.org, nightly build, always updating
pkgver = 99.0a1
-pkgrel = 13
+pkgrel = 14
url = https://blog.nightly.mozilla.org/
arch = i686
arch = x86_64
@@ -17,7 +17,6 @@ depends = nss
provides = firefox-nightly
conflicts = firefox-nightly
source = https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/firefox-VERSION.en-US.linux-ARCH.tar.bz2
-source = https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/firefox-VERSION.en-US.linux-ARCH.txt
source = firefox-nightly.desktop
source = firefox-nightly-safe.desktop
source = vendor.js
diff --git a/PKGBUILD b/PKGBUILD
index a47aec48d036..bc07a1e62449 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer : Félix Saparelli <aur @ passcod.name>
+# Maintainer : Félix Saparelli <felix @ passcod.name>
# Contributor: Cedric MATHIEU <me.xenom @ gmail.com>
# Contributor: coderoar <coderoar @ gmail.com>
# Contributor: Det <nimetonmaili @ gmail.com>
@@ -10,25 +10,24 @@ pkgname=firefox-always-nightly
pkgdesc='Standalone web browser from mozilla.org, nightly build, always updating'
url='https://blog.nightly.mozilla.org/'
pkgver=99.0a1
-pkgrel=13
+pkgrel=14
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
_srcurl="https://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central"
_version="$(curl -s "${_srcurl}/" | grep -Eo firefox-.+tar.bz2 | cut -d- -f2 | cut -d. -f1-2 | tail -n1)"
_file="firefox-${_version}.en-US.linux-${CARCH}"
+_revision="$(curl -s "${_srcurl}/${_file}.txt" | head -n1)"
+_shasum="$(curl -s "${_srcurl}/${_file}.checksums" | grep -E "sha512.+${_file}\.tar\.bz2\$" | cut -d\ -f1)"
-curl -so {,${_srcurl}/}${_file}.checksums
-_sumbz2="$(grep -E sha512.+${_file}\.tar\.bz2\$ ${_file}.checksums | cut -d\ -f1)"
-_sumtxt="$(grep -E sha512.+${_file}\.txt\$ ${_file}.checksums | cut -d\ -f1)"
+pkgver() {
+ echo "${_version}.${_revision}"
+}
-_nametoday="${pkgname}-${pkgver}-$(date +%FT%T)"
-source=("${_nametoday}.tar.bz2::${_srcurl}/${_file}.tar.bz2"
- "${_nametoday}.txt::${_srcurl}/${_file}.txt"
+source=("${pkgname}-$(pkgver).tar.bz2::${_srcurl}/${_file}.tar.bz2"
'firefox-nightly.desktop'
'firefox-nightly-safe.desktop'
'vendor.js')
-sha512sums=("${_sumbz2}"
- "${_sumtxt}"
+sha512sums=("${_shasum}"
'4c318df0ac89dc273f0c1c6a7dcb4e943634bae8c532b4646e833ee5ee2fdd3eaed8da490385b11705e7f7bb6e0679dfd1dc9e070b3b0f9d3f9af7801a934962'
'00caf982c072c7499433c494ecf2096542c4ddf368c4b97fb22672fd669683911d009a65a498b8a03da61ae9aa5a4e8bdaa6e58b148c2a5d7c008910b2af26a5'
'bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010')
@@ -47,10 +46,6 @@ optdepends=('pulseaudio: audio support'
provides=('firefox-nightly')
conflicts=('firefox-nightly')
-pkgver() {
- echo "${_version}.$(head -n1 ${_nametoday}.txt | cut -c-8)"
-}
-
package() {
install -d "${pkgdir}"/{usr/{bin,share/{applications,pixmaps}},opt}
cp -r firefox "${pkgdir}/opt/firefox-nightly"