summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornikatar2019-01-14 18:38:28 +0300
committernikatar2019-01-14 18:38:28 +0300
commit4b2c03896413e7a3d18c3de63b4d73e430fe5c46 (patch)
tree41511f5f2a8908be34ed04c7158f7fe31ea3e208
parent8dfc052487ff71fc125e863c608e9a41ea9e4ea5 (diff)
downloadaur-4b2c03896413e7a3d18c3de63b4d73e430fe5c46.tar.gz
64.0.2-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
-rwxr-xr-xupload-symbol-archive24
3 files changed, 8 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53ab7e270059..410d4f12a3d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-appmenu
pkgdesc = Firefox from extra with appmenu patch
- pkgver = 64.0
+ pkgver = 64.0.2
pkgrel = 1
url = https://aur.archlinux.org/packages/firefox-appmenu/
arch = x86_64
@@ -45,19 +45,18 @@ pkgbase = firefox-appmenu
optdepends = pulseaudio: Audio support
optdepends = speech-dispatcher: Text-to-Speech
optdepends = hunspell-en_US: Spell checking, American English
- provides = firefox=64.0
+ provides = firefox=64.0.2
conflicts = firefox
options = !emptydirs
options = !makeflags
- options = !strip
- source = hg+https://hg.mozilla.org/mozilla-unified#tag=FIREFOX_64_0_RELEASE
+ source = hg+https://hg.mozilla.org/mozilla-unified#tag=FIREFOX_64_0_2_RELEASE
source = firefox.desktop
source = firefox-symbolic.svg
source = unity-menubar.patch
sha256sums = SKIP
sha256sums = 2adca824b52ab5bc6e7e4fa486c1ecb47d283832bd4b75d10494b033f1cab911
sha256sums = 9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797
- sha256sums = 722324ef522f3e2452f49924e47a2e8a3a547e18aef32d7c1252113eb839451f
+ sha256sums = 18d37f79d6919d26c7f581f4c0025b556ced05362749be29af118da05f3cfb51
pkgname = firefox-appmenu
diff --git a/PKGBUILD b/PKGBUILD
index a47e2bb9cea0..3aa3ced540d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=firefox-appmenu
_pkgname=firefox
-pkgver=64.0
+pkgver=64.0.2
pkgrel=1
pkgdesc="Firefox from extra with appmenu patch"
arch=(x86_64)
@@ -23,7 +23,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'hunspell-en_US: Spell checking, American English')
provides=("firefox=$pkgver")
conflicts=("firefox")
-options=(!emptydirs !makeflags !strip)
+options=(!emptydirs !makeflags)
_repo=https://hg.mozilla.org/mozilla-unified
source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
$_pkgname.desktop firefox-symbolic.svg
@@ -49,7 +49,7 @@ prepare() {
mkdir mozbuild
cd mozilla-unified
- # actual appmenu patch from ubuntu repos
+# actual appmenu patch from ubuntu repos
patch -Np1 -i ../unity-menubar.patch
echo -n "$_google_api_key" >google-api-key
@@ -114,7 +114,7 @@ build() {
# LTO needs more open files
ulimit -n 4096
- ./mach build
+ xvfb-run -a -n 97 -s "-screen 0 1600x1200x24" ./mach build
./mach buildsymbols
}
diff --git a/upload-symbol-archive b/upload-symbol-archive
deleted file mode 100755
index 5b61750d2e9d..000000000000
--- a/upload-symbol-archive
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/bash -e
-
-die() {
- echo >&2 "$@"
- exit 1
-}
-
-(( $# >= 2 )) || die "Usage: $0 TOKEN-FILE SYMBOL-ARCHIVE..."
-token="$1"
-shift
-
-[[ -f $token && -s $token ]] || die "Invalid TOKEN-FILE ${token@Q}"
-
-for zip; do
- [[ $(file -Ebi "$zip") == application/zip* ]] || die "Invalid SYMBOL-ARCHIVE ${zip@Q}"
-done
-
-for zip; do
- echo >&2 "Uploading ${zip@Q} ..."
- curl -X POST -H "Auth-Token: $(<"$token")" -F "${zip##*/}=@$zip" \
- --retry 4 --retry-connrefused --connect-timeout 120 \
- https://symbols.mozilla.org/upload/
- echo
-done