summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornikatar2020-12-16 13:28:58 +0300
committernikatar2020-12-16 13:28:58 +0300
commitf94830d414b0796e2a15056b84a4fdb75a11fa4f (patch)
treeb0c8e48bf9f2556f144a8b828aa8333a496ed58e
parentf6932697b5e428d8562f56d59db435dc5c1286f2 (diff)
downloadaur-f94830d414b0796e2a15056b84a4fdb75a11fa4f.tar.gz
84.0-1
-rw-r--r--0001-Use-remoting-name-for-GDK-application-names.patch15
-rw-r--r--PKGBUILD8
-rw-r--r--unity-menubar.patch105
3 files changed, 65 insertions, 63 deletions
diff --git a/0001-Use-remoting-name-for-GDK-application-names.patch b/0001-Use-remoting-name-for-GDK-application-names.patch
index c97bfdfd8ddc..bb0fff9a3ded 100644
--- a/0001-Use-remoting-name-for-GDK-application-names.patch
+++ b/0001-Use-remoting-name-for-GDK-application-names.patch
@@ -5,14 +5,14 @@ Subject: [PATCH] Use remoting name for GDK application names
---
toolkit/xre/nsAppRunner.cpp | 6 +-----
- widget/gtk/nsAppShell.cpp | 11 ++++-------
- 2 files changed, 5 insertions(+), 12 deletions(-)
+ widget/gtk/nsAppShell.cpp | 12 +++++-------
+ 2 files changed, 6 insertions(+), 12 deletions(-)
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
-index a16521852d05..d0be5a088d8c 100644
+index 40e4dae574dc5..cc22fc3f5edaf 100644
--- a/toolkit/xre/nsAppRunner.cpp
+++ b/toolkit/xre/nsAppRunner.cpp
-@@ -3832,11 +3832,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
+@@ -4176,11 +4176,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
// consistently.
// Set program name to the one defined in application.ini.
@@ -26,18 +26,19 @@ index a16521852d05..d0be5a088d8c 100644
// Initialize GTK here for splash.
diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
-index cfe022e65d82..06325264dbb1 100644
+index 24bdd5083375b..74dd54a5ae0e6 100644
--- a/widget/gtk/nsAppShell.cpp
+++ b/widget/gtk/nsAppShell.cpp
-@@ -24,6 +24,7 @@
+@@ -24,6 +24,8 @@
# include "WakeLockListener.h"
#endif
#include "gfxPlatform.h"
+#include "nsAppRunner.h"
++#include "mozilla/XREAppData.h"
#include "ScreenHelperGTK.h"
#include "HeadlessScreenHelper.h"
#include "mozilla/widget/ScreenManager.h"
-@@ -159,13 +160,9 @@ nsresult nsAppShell::Init() {
+@@ -153,13 +155,9 @@ nsresult nsAppShell::Init() {
// See https://bugzilla.gnome.org/show_bug.cgi?id=747634
//
// Only bother doing this for the parent process, since it's the one
diff --git a/PKGBUILD b/PKGBUILD
index 45aec97a688a..ba14ef3ea217 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=firefox-appmenu
_pkgname=firefox
-pkgver=83.0
+pkgver=84.0
pkgrel=1
pkgdesc="Firefox from extra with appmenu patch"
arch=(x86_64)
@@ -29,11 +29,11 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
0001-Use-remoting-name-for-GDK-application-names.patch
$_pkgname.desktop
unity-menubar.patch)
-sha256sums=('d69e84e8b8449f828683d274c24e03095858362bfed21b08bdd7fe715eea5398'
+sha256sums=('23273ef0165b243f5d0908c38e7854d38070282c9b526e8d93b7503cd5f69138'
'SKIP'
- '1dba448eb1605c9dc73c22861a5394b50055909399f056baee4887b29af1b51e'
+ '8b236bbf3ae5cb28d1dd742f543c0079fac06af5aa80bc2051defeba95f0ae21'
'34514a657d6907a159594c51e674eeb81297c431ec26a736417c2fdb995c2c0c'
- 'fdd661b8a41f12e272220c87a5dd07d5846c3099816b90eb2860833910f05969')
+ '6ca4d5a50a6645ff35da0bd2e9b606172f55123ddaec3ed1f87416c18f9800ff')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
diff --git a/unity-menubar.patch b/unity-menubar.patch
index 331d8a71b176..7bc0cd71f7ab 100644
--- a/unity-menubar.patch
+++ b/unity-menubar.patch
@@ -14,10 +14,11 @@
<menu id="file-menu" data-l10n-id="menu-file">
--- a/browser/base/content/browser.js
+++ b/browser/base/content/browser.js
-@@ -6316,11 +6316,17 @@ function onViewToolbarsPopupShowing(aEve
-
+@@ -6427,11 +6427,18 @@ function onViewToolbarsPopupShowing(aEve
+ MozXULElement.insertFTLIfNeeded("browser/toolbarContextMenu.ftl");
+ let firstMenuItem = aInsertPoint || popup.firstElementChild;
let toolbarNodes = gNavToolbox.querySelectorAll("toolbar");
-
++
+ let shellShowingMenubar = document.documentElement.getAttribute("shellshowingmenubar") == "true";
+
for (let toolbar of toolbarNodes) {
@@ -29,9 +30,9 @@
+ continue;
+ }
+
- let menuItem = document.createXULElement("menuitem");
- let hidingAttribute =
- toolbar.getAttribute("type") == "menubar" ? "autohide" : "collapsed";
+ if (toolbar.id == "PersonalToolbar" && gBookmarksToolbar2h2020) {
+ let menu = BookmarkingUI.buildBookmarksToolbarSubmenu(toolbar);
+ popup.insertBefore(menu, firstMenuItem);
--- a/browser/components/places/content/places.xhtml
+++ b/browser/components/places/content/places.xhtml
@@ -169,7 +169,7 @@
@@ -72,32 +73,32 @@
+++ b/dom/xul/moz.build
@@ -83,6 +83,11 @@ LOCAL_INCLUDES += [
- include('/ipc/chromium/chromium-config.mozbuild')
+ include("/ipc/chromium/chromium-config.mozbuild")
-+if CONFIG['MOZ_WIDGET_TOOLKIT'] == 'gtk':
++if CONFIG["MOZ_WIDGET_TOOLKIT"] == "gtk":
+ LOCAL_INCLUDES += [
-+ '/widget/gtk',
++ "/widget/gtk",
+ ]
+
- FINAL_LIBRARY = 'xul'
+ FINAL_LIBRARY = "xul"
- if CONFIG['CC_TYPE'] in ('clang', 'gcc'):
+ if CONFIG["CC_TYPE"] in ("clang", "gcc"):
--- a/layout/build/moz.build
+++ b/layout/build/moz.build
-@@ -67,6 +67,10 @@ elif CONFIG['MOZ_WIDGET_TOOLKIT'] == 'an
- '/dom/system',
- '/dom/system/android',
+@@ -67,6 +67,10 @@ elif CONFIG["MOZ_WIDGET_TOOLKIT"] == "an
+ "/dom/system",
+ "/dom/system/android",
]
-+elif CONFIG['MOZ_WIDGET_TOOLKIT'] == 'gtk':
++elif CONFIG["MOZ_WIDGET_TOOLKIT"] == "gtk":
+ LOCAL_INCLUDES += [
-+ '/widget/gtk',
++ "/widget/gtk",
+ ]
XPCOM_MANIFESTS += [
- 'components.conf',
+ "components.conf",
--- a/modules/libpref/init/all.js
+++ b/modules/libpref/init/all.js
-@@ -312,6 +312,9 @@ pref("dom.mouseevent.click.hack.use_lega
+@@ -320,6 +320,9 @@ pref("dom.mouseevent.click.hack.use_lega
// Fastback caching - if this pref is negative, then we calculate the number
// of content viewers to cache based on the amount of available memory.
pref("browser.sessionhistory.max_total_viewers", -1);
@@ -109,7 +110,7 @@
--- a/toolkit/content/xul.css
+++ b/toolkit/content/xul.css
-@@ -209,6 +209,13 @@ toolbar[type="menubar"] {
+@@ -216,6 +216,13 @@ toolbar[type="menubar"] {
}
%endif
@@ -125,30 +126,30 @@
}
--- a/widget/gtk/moz.build
+++ b/widget/gtk/moz.build
-@@ -56,6 +56,15 @@ UNIFIED_SOURCES += [
+@@ -60,6 +60,15 @@ UNIFIED_SOURCES += [
SOURCES += [
- 'MediaKeysEventSourceFactory.cpp',
-+ 'nsDbusmenu.cpp',
-+ 'nsMenu.cpp', # conflicts with X11 headers
-+ 'nsMenuBar.cpp',
-+ 'nsMenuContainer.cpp',
-+ 'nsMenuItem.cpp',
-+ 'nsMenuObject.cpp',
-+ 'nsMenuSeparator.cpp',
-+ 'nsNativeMenuDocListener.cpp',
-+ 'nsNativeMenuService.cpp',
- 'nsWindow.cpp', # conflicts with X11 headers
- 'WaylandVsyncSource.cpp', # conflicts with X11 headers
+ "MediaKeysEventSourceFactory.cpp",
++ "nsDbusmenu.cpp",
++ "nsMenu.cpp", # conflicts with X11 headers
++ "nsMenuBar.cpp",
++ "nsMenuContainer.cpp",
++ "nsMenuItem.cpp",
++ "nsMenuObject.cpp",
++ "nsMenuSeparator.cpp",
++ "nsNativeMenuDocListener.cpp",
++ "nsNativeMenuService.cpp",
+ "nsWindow.cpp", # conflicts with X11 headers
+ "WaylandVsyncSource.cpp", # conflicts with X11 headers
]
-@@ -136,6 +145,7 @@ LOCAL_INCLUDES += [
- '/layout/base',
- '/layout/forms',
- '/layout/generic',
-+ '/layout/style',
- '/layout/xul',
- '/other-licenses/atk-1.0',
- '/third_party/cups/include',
+@@ -140,6 +149,7 @@ LOCAL_INCLUDES += [
+ "/layout/base",
+ "/layout/forms",
+ "/layout/generic",
++ "/layout/style",
+ "/layout/xul",
+ "/other-licenses/atk-1.0",
+ "/third_party/cups/include",
--- /dev/null
+++ b/widget/gtk/nsDbusmenu.cpp
@@ -0,0 +1,61 @@
@@ -5068,7 +5069,7 @@
+#endif /* __nsNativeMenuService_h__ */
--- a/widget/gtk/nsWindow.cpp
+++ b/widget/gtk/nsWindow.cpp
-@@ -6039,6 +6039,10 @@ void nsWindow::HideWindowChrome(bool aSh
+@@ -6096,6 +6096,10 @@ void nsWindow::HideWindowChrome(bool aSh
SetWindowDecoration(aShouldHide ? eBorderStyle_none : mBorderStyle);
}
@@ -5099,7 +5100,7 @@
/**
* GetLastUserInputTime returns a timestamp for the most recent user input
* event. This is intended for pointer grab requests (including drags).
-@@ -698,6 +702,8 @@ class nsWindow final : public nsBaseWidg
+@@ -701,6 +705,8 @@ class nsWindow final : public nsBaseWidg
static CSDSupportLevel sCSDSupportLevel;
static bool sTransparentMainWindow;
@@ -5110,19 +5111,19 @@
#endif /* __nsWindow_h__ */
--- a/widget/moz.build
+++ b/widget/moz.build
-@@ -69,9 +69,9 @@ elif toolkit == 'cocoa':
- 'nsITouchBarInput.idl',
- 'nsITouchBarUpdater.idl',
+@@ -68,9 +68,9 @@ elif toolkit == "cocoa":
+ "nsITouchBarInput.idl",
+ "nsITouchBarUpdater.idl",
]
- EXPORTS += [
-- 'nsINativeMenuService.h',
+- "nsINativeMenuService.h",
- ]
+
-+if toolkit in ('cocoa', 'gtk'):
-+ EXPORTS += ['nsINativeMenuService.h']
++if toolkit in ("cocoa", "gtk"):
++ EXPORTS += ["nsINativeMenuService.h"]
+
+ TEST_DIRS += ["tests", "tests/gtest"]
- TEST_DIRS += [
- 'tests',
--- /dev/null
+++ b/xpcom/ds/NativeMenuAtoms.py
@@ -0,0 +1,9 @@
@@ -5145,7 +5146,7 @@
import sys
# Static atom definitions, used to generate nsGkAtomList.h.
-@@ -2549,7 +2550,7 @@ STATIC_ATOMS = [
+@@ -2560,7 +2561,7 @@ STATIC_ATOMS = [
InheritingAnonBoxAtom("AnonBox_mozSVGForeignContent", ":-moz-svg-foreign-content"),
InheritingAnonBoxAtom("AnonBox_mozSVGText", ":-moz-svg-text"),
# END ATOMS
@@ -5173,7 +5174,7 @@
if defined('MOZ_X11'):
--- a/xpfe/appshell/AppWindow.cpp
+++ b/xpfe/appshell/AppWindow.cpp
-@@ -66,7 +66,7 @@
+@@ -71,7 +71,7 @@
# include "mozilla/XULStore.h"
#endif