summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2018-02-25 22:40:24 -0400
committerYour Name2018-02-25 22:40:24 -0400
commite49e793760faf60abab3701f34d281524b011741 (patch)
tree282e00ee13d7ac4049c4cddd797c0717ebd4dc2c
parent70021141d689d1ff5c094882424a832ac5d0a5c2 (diff)
downloadaur-e49e793760faf60abab3701f34d281524b011741.tar.gz
b12 and some optimizations
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3a04351cdc8..f0f33d4ed04c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-beta
pkgdesc = Standalone web browser from mozilla.org, with telemetry, webrtc and signing disabled
- pkgver = 59.0.11
+ pkgver = 59.0.12
pkgrel = 1
url = https://www.mozilla.org/firefox/
arch = i686
@@ -44,7 +44,7 @@ pkgbase = firefox-beta
options = !emptydirs
options = !makeflags
options = !strip
- source = https://hg.mozilla.org/mozilla-unified/archive/FIREFOX_59_0b11_RELEASE.tar.gz
+ source = https://hg.mozilla.org/mozilla-unified/archive/FIREFOX_59_0b12_RELEASE.tar.gz
source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-beta.desktop
source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-symbolic.svg
source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-52-disable-data-sharing-infobar.patch
@@ -53,7 +53,7 @@ pkgbase = firefox-beta
source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/id.patch
source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/fix.patch
source = https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/fix2.patch
- sha256sums = aa07467168556411f6480e9d86a4b33a797fb39c778480520ee4a130f406dba8
+ sha256sums = ef0b35b5f9ba9c54848ef49f056d8f8c7ed2fb75add12669b923440039dfb5bb
sha256sums = d6b4c91a7fe77f9a335b44b943e120ce44511e46bbb16ae305cc82b4c3db66cd
sha256sums = a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9
sha256sums = bdad68eafe110b9f94a0e025635e32a6ab53e2f9adcd594c8dd2e3225f6453ab
diff --git a/PKGBUILD b/PKGBUILD
index 6ffdd01005c9..5e5f6b4f79a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,9 @@
pkgname=firefox-beta
name=firefox-beta
-pkgver=59.0.11
+pkgver=59.0.12
pkgrel=1
+meme=FIREFOX_59_0b12_RELEASE
pkgdesc="Standalone web browser from mozilla.org, with telemetry, webrtc and signing disabled"
arch=(i686 x86_64)
license=(MPL GPL LGPL)
@@ -20,7 +21,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech')
options=(!emptydirs !makeflags !strip)
-source=("https://hg.mozilla.org/mozilla-unified/archive/FIREFOX_59_0b11_RELEASE.tar.gz"
+source=("https://hg.mozilla.org/mozilla-unified/archive/$meme.tar.gz"
https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/$name.desktop
https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-symbolic.svg
https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/firefox-52-disable-data-sharing-infobar.patch
@@ -31,7 +32,7 @@ https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/fix.patch
https://raw.githubusercontent.com/bn0785ac/firefox-beta/master/fix2.patch
)
-sha256sums=('aa07467168556411f6480e9d86a4b33a797fb39c778480520ee4a130f406dba8'
+sha256sums=('ef0b35b5f9ba9c54848ef49f056d8f8c7ed2fb75add12669b923440039dfb5bb'
'd6b4c91a7fe77f9a335b44b943e120ce44511e46bbb16ae305cc82b4c3db66cd'
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
'bdad68eafe110b9f94a0e025635e32a6ab53e2f9adcd594c8dd2e3225f6453ab'
@@ -58,7 +59,7 @@ prepare() {
mkdir path
ln -s /usr/bin/python2 path/python
- cd mozilla-unified-FIREFOX_59_0b11_RELEASE
+ cd mozilla-unified-$meme
patch -Np1 -i ../id.patch
@@ -127,7 +128,7 @@ END
}
build() {
- cd mozilla-unified-FIREFOX_59_0b11_RELEASE
+ cd mozilla-unified-$meme
# _FORTIFY_SOURCE causes configure failures
CPPFLAGS+=" -O2"
@@ -143,7 +144,7 @@ build() {
}
package() {
- cd mozilla-unified-FIREFOX_59_0b11_RELEASE
+ cd mozilla-unified-$meme
DESTDIR="$pkgdir" ./mach install
find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +
@@ -211,4 +212,4 @@ msg2 'renaming'
rm "$pkgdir/usr/bin/firefox"
-} \ No newline at end of file
+}