summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2023-11-29 18:03:25 +0100
committerSimon Brulhart2023-11-29 18:05:38 +0100
commitdd267a6bcdfde1658f63c145b20b3c36d3a75718 (patch)
treedac0a5e73d268ba6bf90a21cbc3c2be02950eeee
parent103d28c6abac0c73e3754d53bdc57ddf6984f015 (diff)
downloadaur-dd267a6bcdfde1658f63c145b20b3c36d3a75718.tar.gz
Disable popup on auto-update failure
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--policies.json5
3 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad4d41af6f1a..0dbd920447d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,8 +25,10 @@ pkgbase = firefox-beta-bin
source = https://archive.mozilla.org/pub/firefox/candidates/121.0b5-candidates/build1/linux-x86_64/en-US/firefox-121.0b5.tar.bz2
source = firefox-beta.sh
source = firefox-beta-bin.desktop
+ source = policies.json
sha256sums = afecb7f9572e7fbbee4107b044038ff0ce7b2f4c974a9c260ebd77f99e9f8060
sha256sums = 4bec62032e49c28ff27750abddbdbdbb1a4b5cba719c39498968fe53adee790b
sha256sums = 210f13ea47c4b96387f26ee7fc4dfc5c192cfb169aef2a13303fbd1ee58b3761
+ sha256sums = 2d7e8d947c392142dba0c80a7e5ecfdf14f7783e24885ab417d4224574b8c4f8
pkgname = firefox-beta-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6dda0d405271..247a4d3b5a14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,10 +24,12 @@ conflicts=('firefox-beta')
install=$pkgname.install
source=("https://archive.mozilla.org/pub/firefox/candidates/121.0b5-candidates/build1/linux-x86_64/en-US/firefox-$pkgver.tar.bz2"
"$_pkgname.sh"
- "$pkgname.desktop")
+ "$pkgname.desktop"
+ "policies.json")
sha256sums=('afecb7f9572e7fbbee4107b044038ff0ce7b2f4c974a9c260ebd77f99e9f8060'
'4bec62032e49c28ff27750abddbdbdbb1a4b5cba719c39498968fe53adee790b'
- '210f13ea47c4b96387f26ee7fc4dfc5c192cfb169aef2a13303fbd1ee58b3761')
+ '210f13ea47c4b96387f26ee7fc4dfc5c192cfb169aef2a13303fbd1ee58b3761'
+ '2d7e8d947c392142dba0c80a7e5ecfdf14f7783e24885ab417d4224574b8c4f8')
# RC
if [[ $_build = ? ]]; then
source[0]="firefox-$pkgver.tar.bz2::https://ftp.mozilla.org/pub/firefox/candidates/$_major-candidates/build$_build/linux-x86_64/en-US/firefox-$_major.tar.bz2"
@@ -43,6 +45,7 @@ package() {
msg2 "Moving stuff in place..."
# Install
cp -r firefox/ "$pkgdir"/opt/$_pkgname
+ install -m644 policies.json -D -t "$pkgdir"/opt/$_pkgname/policies/
# Launchers
install -m755 $_pkgname.sh "$pkgdir"/usr/bin/$_pkgname
diff --git a/policies.json b/policies.json
new file mode 100644
index 000000000000..1f4d0f25bb85
--- /dev/null
+++ b/policies.json
@@ -0,0 +1,5 @@
+{
+ "policies": {
+ "AppAutoUpdate": false
+ }
+}