summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2024-04-14 22:26:28 +0200
committerSimon Brulhart2024-04-14 22:26:28 +0200
commit1b8f6f6744d947874094431a52c28d9ec0a3df9f (patch)
treec80f3901dc830326e23d25e139b13b7abafcceaf
parentcdfd4078aa8e561d0d22e04f5ff838e6c8853522 (diff)
downloadaur-1b8f6f6744d947874094431a52c28d9ec0a3df9f.tar.gz
Fix policy to disable auto-update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--policies.json2
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95b71de5a628..0377b5955cf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-beta-bin-all-localizations
pkgdesc = Perl script for installing latest FF beta in the language of your choice
pkgver = 125.0rc1
- pkgrel = 1
+ pkgrel = 2
url = https://www.mozilla.com/firefox/channel/#beta
arch = i686
arch = x86_64
@@ -30,6 +30,6 @@ pkgbase = firefox-beta-bin-all-localizations
md5sums = 4c0ca11a8034b53c0c5b7b9830442cd7
md5sums = b4d5afd97c8ac229f6027d7853c73c0c
md5sums = 68c9e357994d714b25f91be9db2a8594
- md5sums = 52dd66218eaa583c70790fde3bf74045
+ md5sums = 2756ce31c6f1fbabd237a268f4339155
pkgname = firefox-beta-bin-all-localizations
diff --git a/PKGBUILD b/PKGBUILD
index 41afee11fb8d..e47056262508 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname=firefox-beta
pkgdesc='Perl script for installing latest FF beta in the language of your choice'
url='https://www.mozilla.com/firefox/channel/#beta'
pkgver=125.0rc1
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
depends=('gtk3' 'libxt' 'dbus-glib' 'nss')
@@ -30,7 +30,7 @@ package() {
mkdir -p "${pkgdir}"/usr/{lib,bin,share/applications}
cp -r firefox "${pkgdir}/usr/lib/${_pkgname}"
- install -m644 "${srcdir}/policies.json" -D -t "${pkgdir}/usr/lib/${_pkgname}/policies/"
+ install -m644 "${srcdir}/policies.json" -D -t "${pkgdir}/usr/lib/${_pkgname}/distribution/"
install -m755 "${srcdir}/firefox-beta.sh" "${pkgdir}/usr/bin/firefox-beta"
# Use system-provided dictionaries and hyphenation
@@ -50,4 +50,4 @@ package() {
md5sums=('4c0ca11a8034b53c0c5b7b9830442cd7'
'b4d5afd97c8ac229f6027d7853c73c0c'
'68c9e357994d714b25f91be9db2a8594'
- '52dd66218eaa583c70790fde3bf74045')
+ '2756ce31c6f1fbabd237a268f4339155')
diff --git a/policies.json b/policies.json
index 1f4d0f25bb85..f36622021fcd 100644
--- a/policies.json
+++ b/policies.json
@@ -1,5 +1,5 @@
{
"policies": {
- "AppAutoUpdate": false
+ "DisableAppUpdate": true
}
}