summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohnnybash2021-01-12 20:26:00 +0100
committerjohnnybash2021-01-12 20:26:00 +0100
commit1b335443178f1747ac8dbba6edb9910dbfba616e (patch)
tree7f2c888dee66c11c40a7703215be0fa9f8c0f98b
downloadaur-1b335443178f1747ac8dbba6edb9910dbfba616e.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38261b6e23f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = firefox-binnenibegone
+ pkgdesc = remove so called Binnen-Is on webpages
+ pkgver = 2.7
+ pkgrel = 1
+ url = https://addons.mozilla.org/en-US/firefox/addon/binnen-i-be-gone/
+ arch = any
+ license = GPL3
+ noextract = binnen_i_be_gone-2.7-an+fx.xpi
+ source = https://addons.mozilla.org/firefox/downloads/file/3628157/binnen_i_be_gone-2.7-an+fx.xpi
+ sha512sums = ae736ca7a6ff166db082a64b5160d512ddecdc87014635a267f2001b3800f61fa4db46c0df83f7bd9b18dc10737658049b4c28c8c5cc869b1d2a690139c28f63
+ b2sums = aa381e199e702a2ee37339f19586abdbf047c28d77f728d3f38cbac457cb937da2b5c62c9e1c17b4a5f8c56009286e17abfde064106c599999f649df68df3171
+
+pkgname = firefox-binnenibegone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..031aded21b8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: johnnybash <jb at wachenzell dot org> PGP D126E2910543DE2D
+
+pkgname=firefox-binnenibegone
+pkgver=2.7
+pkgrel=1
+pkgdesc="remove so called Binnen-Is on webpages"
+url=https://addons.mozilla.org/en-US/firefox/addon/binnen-i-be-gone/
+arch=("any")
+license=("GPL3")
+source=("https://addons.mozilla.org/firefox/downloads/file/3628157/binnen_i_be_gone-$pkgver-an+fx.xpi")
+noextract=("${source##*/}")
+b2sums=("aa381e199e702a2ee37339f19586abdbf047c28d77f728d3f38cbac457cb937da2b5c62c9e1c17b4a5f8c56009286e17abfde064106c599999f649df68df3171")
+sha512sums=("ae736ca7a6ff166db082a64b5160d512ddecdc87014635a267f2001b3800f61fa4db46c0df83f7bd9b18dc10737658049b4c28c8c5cc869b1d2a690139c28f63")
+
+package() {
+ install -Dm644 "${source##*/}" "$pkgdir"/usr/lib/firefox/browser/extensions/{b65d7d9a-4ec0-4974-b07f-83e30f6e973f}.xpi
+}
+
+# vim:set ts=2 sw=2 et: