summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpapajoker2017-09-11 12:21:52 +0200
committerpapajoker2017-09-11 12:21:52 +0200
commit611fd40ada2433160015c567849e014af61883ce (patch)
treef50b6453f3a18a0da4fb19a17113202d5a0c802a
parentc11f4ae9be182348cad05259bba14b4fd84369d5 (diff)
downloadaur-611fd40ada2433160015c567849e014af61883ce.tar.gz
best source update
-rwxr-xr-xupdate-pkg.sh3
1 files changed, 2 insertions, 1 deletions
diff --git a/update-pkg.sh b/update-pkg.sh
index 548cabdaaf16..e5d52b217ad3 100755
--- a/update-pkg.sh
+++ b/update-pkg.sh
@@ -1,8 +1,9 @@
#!/usr/bin/bash
# get last pkgver
-pkgver=$(curl -s https://hg.mozilla.org/releases/mozilla-beta/tags | grep -Eo ">FIREFOX_.*_.*_RELEASE<" -m1 | awk -F'_' '{print $2"."$3}')
+pkgver=$(curl -s "https://ftp.mozilla.org/pub/devedition/releases/" | awk -F'/' '/href.*releases\// {print $5}' | sort -Vr | head -n1)
echo "last FF-dev release: ${pkgver}"
+
sed -i -e "s/pkgver=.*/pkgver=${pkgver}/" ./PKGBUILD
#makepkg -g -f -p PKGBUILD