summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTamás Barta2017-08-18 12:45:09 +0200
committerTamás Barta2017-08-18 12:45:09 +0200
commit573660d0b8fc2b8fd5033ed000470881d7516a24 (patch)
treea7f5daef6ee1903069b847c8b768e5ddf094b6a0
downloadaur-573660d0b8fc2b8fd5033ed000470881d7516a24.tar.gz
first commit, Firefox 56.0b3, based on firefox-developer-da
-rw-r--r--.SRCINFO40
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD87
-rw-r--r--firefox-developer.desktop12
-rw-r--r--vendor.js2
5 files changed, 148 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2eca41f57275
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = firefox-developer-hu
+ pkgdesc = Standalone web browser from mozilla.org, developer build - Hungarian
+ pkgver = 56.0b3
+ pkgrel = 1
+ url = http://www.mozilla.org/firefox/developer
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = dbus-glib
+ depends = gtk3
+ depends = libxt
+ depends = mime-types
+ depends = nss
+ depends = sqlite
+ optdepends = alsa-lib: An alternative implementation of Linux sound support
+ optdepends = ffmpeg: Complete solution to record, convert and stream audio and video
+ optdepends = gtk2: flash plugin support
+ optdepends = gtk3-print-backends: Print support
+ optdepends = hunspell: Spell checking
+ optdepends = hyphen: Hyphenation
+ optdepends = libnotify: Notification integration
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = pulseaudio: Audio/video playback
+ optdepends = speech-dispatcher: Text to Speech
+ optdepends = startup-notification: Support for FreeDesktop Startup Notification
+ source = https://download-installer.cdn.mozilla.net/pub/devedition/releases/56.0b3/linux-x86_64/hu/firefox-56.0b3.tar.bz2
+ source = https://download-installer.cdn.mozilla.net/pub/devedition/releases/56.0b3/SHA512SUMS
+ source = https://download-installer.cdn.mozilla.net/pub/devedition/releases/56.0b3/SHA512SUMS.asc
+ source = firefox-developer.desktop
+ source = vendor.js
+ validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
+ sha512sums = 0a9d618609f913c4a20c9bf10a36b298d8a9eb5ba4c9f58d92416b605d4887db69467a25b26f51ca8d931b2a3aacf7ec6e5ad2efb99aa89ac620c22e596a6b19
+ sha512sums = 1d85e3e2e26b9674a074bd9aea35590af5e66f1f313fb642194424705f77ed484ea8899f1205b72d9f6d90d5273bf10d0fc033a878d2afc370f1d8da175f8856
+ sha512sums = SKIP
+ sha512sums = b109b884ed79e9e214541750a0fcac8d7d8891cc7f0e0d472b717a5b71e569ab5852534bceaab045a5b13a9290a7905604d08fe97e28c675a2266c30fe719cb6
+ sha512sums = bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010
+
+pkgname = firefox-developer-hu
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..603386d777ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/src/
+/pkg/
+*.tar.bz2
+*.pkg.tar.xz
+SHA512SUMS
+SHA512SUMS.asc
+/update-aur.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d630ca6183d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,87 @@
+# Maintainer Tamás Barta <barta dot tamas dot d at gmail dot com>
+# Based on PKGBUILD:
+# * `firefox-developer`
+# * `firefox-developer-es-mx`
+# * `firefox-developer-de`
+# * `firefox-developer-da`
+# Fontos: a "Mozilla Sofware Releases <release@mozilla.com>" PGP kulcs importálása szükséges
+# $ gpg --keyserver pgp.mit.edu --recv-keys 14F26682D0916CDD81E37B6D61B7B526D98F0353
+
+_name=firefox
+_channel=developer
+_lang=hu
+
+pkgname="${_name}-${_channel}-${_lang}"
+pkgdesc='Standalone web browser from mozilla.org, developer build - Hungarian'
+url='http://www.mozilla.org/firefox/developer'
+pkgver='56.0b3'
+pkgrel=1
+arch=('x86_64')
+license=('MPL' 'GPL' 'LGPL')
+_file="${_name}-${pkgver}"
+_url="https://download-installer.cdn.mozilla.net/pub/devedition/releases/${pkgver}"
+_loc="linux-${arch}/${_lang}"
+source=("${_url}/${_loc}/${_file}.tar.bz2"
+ "${_url}/SHA512SUMS"
+ "${_url}/SHA512SUMS.asc"
+ "${_name}-${_channel}.desktop"
+ "vendor.js")
+sha512sums=('0a9d618609f913c4a20c9bf10a36b298d8a9eb5ba4c9f58d92416b605d4887db69467a25b26f51ca8d931b2a3aacf7ec6e5ad2efb99aa89ac620c22e596a6b19'
+ '1d85e3e2e26b9674a074bd9aea35590af5e66f1f313fb642194424705f77ed484ea8899f1205b72d9f6d90d5273bf10d0fc033a878d2afc370f1d8da175f8856'
+ 'SKIP'
+ 'b109b884ed79e9e214541750a0fcac8d7d8891cc7f0e0d472b717a5b71e569ab5852534bceaab045a5b13a9290a7905604d08fe97e28c675a2266c30fe719cb6'
+ 'bae5a952d9b92e7a0ccc82f2caac3578e0368ea6676f0a4bc69d3ce276ef4f70802888f882dda53f9eb8e52911fb31e09ef497188bcd630762e1c0f5293cc010')
+validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla’s GnuPG release key
+# Dependencies
+# https://www.archlinux.org/packages/extra/x86_64/firefox/
+depends=('dbus-glib' 'gtk3' 'libxt' 'mime-types' 'nss' 'sqlite')
+optdepends=(
+ 'alsa-lib: An alternative implementation of Linux sound support'
+ 'ffmpeg: Complete solution to record, convert and stream audio and video'
+ 'gtk2: flash plugin support'
+ 'gtk3-print-backends: Print support'
+ 'hunspell: Spell checking'
+ 'hyphen: Hyphenation'
+ 'libnotify: Notification integration'
+ 'networkmanager: Location detection via available WiFi networks'
+ 'pulseaudio: Audio/video playback'
+ 'speech-dispatcher: Text to Speech'
+ 'startup-notification: Support for FreeDesktop Startup Notification'
+)
+
+prepare() {
+ msg "!> Fontos: a 'Mozilla Sofware Releases' <release@mozilla.com>"
+ msg "!> PGP kulcs importálása szükséges"
+ msg "!> További információt itt találhat:"
+ msg "!> <https://wiki.archlinux.org/index.php/GnuPG#Import_a_public_key>"
+ msg "!> $ gpg --keyserver pgp.mit.edu --recv-keys D98F0353"
+
+ # Check if hash of the source archive matches the one provided by Mozilla (which was signed with GPG).
+ _checksum=`grep "linux-x86_64/$_lang/firefox-$pkgver.tar.bz2" $srcdir/SHA512SUMS | cut -f1 -d " "`
+ _actual=`sha512sum $srcdir/firefox-$pkgver.tar.bz2 | cut -f1 -d " "`
+
+ msg "!> Checking integrity of firefox-$pkgver.tar.bz2"
+
+ if [[ $_checksum == $_actual ]];
+ then
+ msg "!> Integrity verified successfully."
+ else
+ msg "!> Integrity verification failed!"
+ exit 1
+ fi
+}
+
+package() {
+ opt_path="opt/${pkgname}"
+ # install binaries
+ install -d $pkgdir/{usr/{bin,share/{applications,pixmaps}},opt}
+ cp -r firefox $pkgdir/${opt_path}
+ # symlink binary
+ ln -s /${opt_path}/firefox $pkgdir/usr/bin/$_name-$_channel
+ # install icon
+ install -m644 $srcdir/firefox/browser/icons/mozicon128.png $pkgdir/usr/share/pixmaps/$_name-${_channel}-icon.png
+ # install desktop file
+ install -m644 $srcdir/$_name-$_channel.desktop $pkgdir/usr/share/applications/
+ # install vendor.js file
+ install -Dm644 $srcdir/vendor.js $pkgdir/opt/$_name-$_channel/browser/defaults/preferences/vendor.js
+}
diff --git a/firefox-developer.desktop b/firefox-developer.desktop
new file mode 100644
index 000000000000..ae22888d5c94
--- /dev/null
+++ b/firefox-developer.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=Firefox Developer
+GenericName=Web Browser
+Icon=firefox-developer-icon
+Type=Application
+Categories=Application;Network;
+MimeType=text/html
+Encoding=UTF-8
+Exec=firefox-developer --class=firefox-developer %u
+Terminal=false
+MultipleArgs=false
+StartupNotify=true
diff --git a/vendor.js b/vendor.js
new file mode 100644
index 000000000000..caa38c691d4d
--- /dev/null
+++ b/vendor.js
@@ -0,0 +1,2 @@
+// Disable update check
+pref("app.update.enabled", false);