summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2022-09-07 16:12:39 +0100
committerJonathon Fernyhough2022-09-07 16:12:39 +0100
commit1390fb9d3f5c9b027089095beaa4fb394bcc43e3 (patch)
tree69e7164a8bbea7b669db76b3e15c119c07bf1cfe
parent4254af19fd23ec937851859c10a83b681e009d2a (diff)
downloadaur-1390fb9d3f5c9b027089095beaa4fb394bcc43e3.tar.gz
Adopt change from firefox-nightly, switch to pip
106.0a1+20220901.1+haf1fc1e6eb24-1: Switch to pip; system python packages broke the build again
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--zstandard-0.18.0.diff10
3 files changed, 7 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf4d6dc7b493..261993e71473 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-esr
pkgdesc = Standalone web browser from mozilla.org, Extended Support Release
pkgver = 102.2.0
- pkgrel = 1
+ pkgrel = 1.0
url = https://www.mozilla.org/en-US/firefox/enterprise/
arch = x86_64
license = MPL
@@ -23,8 +23,7 @@ pkgbase = firefox-esr
makedepends = nodejs
makedepends = cbindgen
makedepends = nasm
- makedepends = python-setuptools
- makedepends = python-zstandard
+ makedepends = python
makedepends = lld
makedepends = dump_syms
makedepends = wasi-compiler-rt
@@ -149,7 +148,6 @@ pkgbase = firefox-esr
source = https://archive.mozilla.org/pub/firefox/releases/102.2.0esr/source/firefox-102.2.0esr.source.tar.xz
source = https://archive.mozilla.org/pub/firefox/releases/102.2.0esr/source/firefox-102.2.0esr.source.tar.xz.asc
source = cbindgen-0.24.0.diff
- source = zstandard-0.18.0.diff
source = update-packed_simd.diff
source = arc4random.diff
source = firefox-esr.desktop
@@ -254,7 +252,6 @@ pkgbase = firefox-esr
sha512sums = 06d753867ccfe1b2c79148cc60bc816b47a2abfa98219808868e9028bef1763d982ef7012698d06b8959cce79163d7926baf5f9d5ca9daa18c51fbf0efc59993
sha512sums = SKIP
sha512sums = 3526402ccae1f0428f2e45bae8d0b2cb909ac2698bc3508b692b827839ccb21203ce414206039776f6ce946fc53e636290b7870e9886284d5e9d1e8ad050aac9
- sha512sums = c949cf492bc93b6f3f1f827744e0f39e555c518434c8e73e27143a769b0d123fe4ba2cae07b7b7e7b594f8da43383d4fb4cd28b6b52e0d3e7a985afbadfb3d04
sha512sums = 1377b852680667b378ae97e073149230067ad2dc03e4dd53ca59239e6f8542156c5e27239504a0540f0b1254fc9e43c93cf2575ba0bcfcb2ad74f37bc4961c5a
sha512sums = 9cbc214c3ae7b93ef6c0573194dc7600dd0b4bb6f2653693d75b08475b7c3d65f6a181055060848143b488207c39af3fdb7382bb45de5264b2daedcb62bf97f2
sha512sums = 4b53ee133a4ecaf068e240f6a05a1ebf4b788d67fe9141cc5b3561e1128907c8c3edb49bf2b24ba89daf1552f94ac48adf682dbe7dd070cffe7f78d98f2b3338
diff --git a/PKGBUILD b/PKGBUILD
index c9048524143d..ec4df5ac389b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgbase=firefox-esr
pkgname=(firefox-esr)
pkgver=102.2.0
-pkgrel=1
+pkgrel=1.0
pkgdesc="Standalone web browser from mozilla.org, Extended Support Release"
arch=(x86_64)
license=(MPL GPL LGPL)
@@ -18,7 +18,7 @@ url="https://www.mozilla.org/en-US/firefox/enterprise/"
depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm jack nodejs cbindgen nasm
- python-setuptools python-zstandard lld dump_syms
+ python lld dump_syms
wasi-compiler-rt wasi-libc wasi-libc++ wasi-libc++abi)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
@@ -28,7 +28,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'xdg-desktop-portal: Screensharing with Wayland')
options=(!emptydirs !makeflags !strip !lto !debug)
source=(https://archive.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz{,.asc}
- cbindgen-0.24.0.diff zstandard-0.18.0.diff update-packed_simd.diff arc4random.diff
+ cbindgen-0.24.0.diff update-packed_simd.diff arc4random.diff
$pkgname.desktop identity-icons-brand.svg)
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@@ -45,7 +45,7 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_mozilla_api_key=e05d56db0a694edc8b5aaebda3f2db6a
prepare() {
- mkdir mozbuild
+ mkdir -p mozbuild
cd firefox-$pkgver
echo "${noextract[@]}"
@@ -53,9 +53,6 @@ prepare() {
# Unbreak build with cbindgen 0.24.0
patch -Np1 -i ../cbindgen-0.24.0.diff
- # Unbreak build with python-zstandard 0.18.0
- patch -Np1 -i ../zstandard-0.18.0.diff
-
# Unbreak build with simd
patch -Np1 -i ../update-packed_simd.diff
@@ -114,7 +111,7 @@ build() {
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
export MOZ_ENABLE_FULL_SYMBOLS=1
- export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system
+ export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=pip
export MOZ_BUILD_DATE=$(head -1 sourcestamp.txt)
export RUSTFLAGS="-C debuginfo=1"
@@ -360,7 +357,6 @@ done
sha512sums=('06d753867ccfe1b2c79148cc60bc816b47a2abfa98219808868e9028bef1763d982ef7012698d06b8959cce79163d7926baf5f9d5ca9daa18c51fbf0efc59993'
'SKIP'
'3526402ccae1f0428f2e45bae8d0b2cb909ac2698bc3508b692b827839ccb21203ce414206039776f6ce946fc53e636290b7870e9886284d5e9d1e8ad050aac9'
- 'c949cf492bc93b6f3f1f827744e0f39e555c518434c8e73e27143a769b0d123fe4ba2cae07b7b7e7b594f8da43383d4fb4cd28b6b52e0d3e7a985afbadfb3d04'
'1377b852680667b378ae97e073149230067ad2dc03e4dd53ca59239e6f8542156c5e27239504a0540f0b1254fc9e43c93cf2575ba0bcfcb2ad74f37bc4961c5a'
'9cbc214c3ae7b93ef6c0573194dc7600dd0b4bb6f2653693d75b08475b7c3d65f6a181055060848143b488207c39af3fdb7382bb45de5264b2daedcb62bf97f2'
'4b53ee133a4ecaf068e240f6a05a1ebf4b788d67fe9141cc5b3561e1128907c8c3edb49bf2b24ba89daf1552f94ac48adf682dbe7dd070cffe7f78d98f2b3338'
diff --git a/zstandard-0.18.0.diff b/zstandard-0.18.0.diff
deleted file mode 100644
index 5dfa30557dcf..000000000000
--- a/zstandard-0.18.0.diff
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git i/python/sites/mach.txt w/python/sites/mach.txt
-index 01f4f8c23da3b..85cfaf2b273ac 100644
---- i/python/sites/mach.txt
-+++ w/python/sites/mach.txt
-@@ -134,4 +134,4 @@ pypi-optional:glean-sdk==50.1.0:telemetry will not be collected
- # We aren't (yet) able to pin packages in automation, so we have to
- # support down to the oldest locally-installed version (5.4.2).
- pypi-optional:psutil>=5.4.2,<=5.8.0:telemetry will be missing some data
--pypi-optional:zstandard>=0.11.1,<=0.17.0:zstd archives will not be possible to extract
-+pypi-optional:zstandard>=0.11.1,<=0.18.0:zstd archives will not be possible to extract