summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Retornaz2017-06-14 02:46:24 +0200
committerQuentin Retornaz2017-06-14 02:46:24 +0200
commit732f38524d84e801bbc18de3f89c7701c85d94cd (patch)
tree55abe97a4b74eaf35b47e2204ab17eb740d07172
parent53197474714e1a410f44d26314e8a6edfa5d0efa (diff)
downloadaur-732f38524d84e801bbc18de3f89c7701c85d94cd.tar.gz
pkgver: 52.2.0
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch48
-rw-r--r--0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch25
-rw-r--r--PKGBUILD28
4 files changed, 108 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27c5cb83227d..ce797818e5d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat May 20 18:11:58 UTC 2017
+# Wed Jun 14 00:44:24 UTC 2017
pkgbase = firefox-esr-gtk2
pkgdesc = Standalone web browser from mozilla.org, Extended Support Release
- pkgver = 52.1.2
+ pkgver = 52.2.0
pkgrel = 1
url = https://www.mozilla.org/en-US/firefox/organizations/
arch = i686
@@ -41,20 +41,24 @@ pkgbase = firefox-esr-gtk2
optdepends = networkmanager: Location detection via available WiFi networks
optdepends = libnotify: Notification integration
optdepends = speech-dispatcher: Text-to-Speech
- provides = firefox=52.1.2
+ provides = firefox=52.2.0
conflicts = firefox
replaces = firefox-gtk2
options = !emptydirs
options = !makeflags
options = !strip
- source = https://ftp.mozilla.org/pub/firefox/releases/52.1.2esr/source/firefox-52.1.2esr.source.tar.xz
+ source = https://ftp.mozilla.org/pub/firefox/releases/52.2.0esr/source/firefox-52.2.0esr.source.tar.xz
source = firefox.desktop
source = firefox-symbolic.svg
+ source = 0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
+ source = 0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch
source = firefox-install-dir.patch
source = fix-wifi-scanner.diff
- sha256sums = 388e0454d69801f0f2010f8f93b796420ec0493fbf138fc659dbd5b497b8373b
+ sha256sums = a2f180e4109b15d86d58444134996c1d49eb52e7702d89510508fbd7bddb9381
sha256sums = ada313750e6fb14558b37c764409a17c1672a351a46c73b350aa1fe4ea9220ef
sha256sums = a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9
+ sha256sums = 413cd6d366d78f325d80ebebccfd0afa0d266b40b2e54b66ba2fa03c15f3ea67
+ sha256sums = 93c495526c1a1227f76dda5f3a43b433bc7cf217aaf74bd06b8fc187d285f593
sha256sums = d86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd
sha256sums = 9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8
diff --git a/0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch b/0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
new file mode 100644
index 000000000000..cf2e0eb9b80b
--- /dev/null
+++ b/0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
@@ -0,0 +1,48 @@
+From bbd48a5613c872883616884cfaf41665b0e4ec9b Mon Sep 17 00:00:00 2001
+From: Ralph Giles <giles@mozilla.com>
+Date: Fri, 10 Feb 2017 12:58:18 -0800
+Subject: [PATCH] Bug 1338655 - Don't try to build mp4parse bindings. r=froydnj
+
+We use the cheddar crate to generate a C header file
+for our mp4parse_capi wrapper crate. Currently we
+do this at code check-in time via update-rust.sh.
+
+Cargo 0.18 and later will try to execute a build.rs
+file in the crate source tree regardless of whether
+it's specified in Cargo.toml so patching out that
+line just results in 'crate cheddar not found'.
+
+This change restores the old behaviour by substituting
+a 'build = false' line instead.
+
+We do have syntex vendored, but we don't currently build
+it by default, so I prefer this solution to just vendoring
+cheddar and generating the header at build time. The syntex
+crate is quite large and adds significantly to our compile
+time.
+
+MozReview-Commit-ID: InJRRODWAdP
+
+--HG--
+extra : rebase_source : 29378fcbc86015ce6cc22dc66d38a43ddbac204e
+---
+ media/libstagefright/binding/mp4parse-cargo.patch | 5 +++--
+ media/libstagefright/binding/mp4parse_capi/Cargo.toml | 2 ++
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/media/libstagefright/binding/mp4parse_capi/Cargo.toml b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+index aee7ee947151a27c..d7e3f55119d3f4b6 100644
+--- a/media/libstagefright/binding/mp4parse_capi/Cargo.toml
++++ b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+@@ -18,6 +18,8 @@ exclude = [
+ "*.mp4",
+ ]
+
++build = false
++
+ [dependencies]
+ byteorder = "1.0.0"
+ "mp4parse" = {version = "0.6.0", path = "../mp4parse"}
+--
+2.12.2
+
diff --git a/0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch b/0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch
new file mode 100644
index 000000000000..0cdbaa33b117
--- /dev/null
+++ b/0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch
@@ -0,0 +1,25 @@
+--- a/old-configure.in 2017-05-12 22:21:13.000000000 +0200
++++ b/old-configure.in 2017-06-14 00:21:17.128183411 +0200
+@@ -2127,7 +2127,7 @@
+ fi
+
+ if test -n "$MOZ_SYSTEM_NSS"; then
+- NSS_LIBS="$NSS_LIBS -lcrmf"
++ NSS_LIBS="$NSS_LIBS"
+ else
+ NSS_CFLAGS="-I${DIST}/include/nss"
+ fi
+
+--- a/security/manager/ssl/moz.build 2017-04-11 04:13:24.000000000 +0200
++++ b/security/manager/ssl/moz.build 2017-06-14 01:03:48.295633516 +0200
+@@ -184,10 +184,6 @@
+
+ DEFINES['CERT_AddTempCertToPerm'] = '__CERT_AddTempCertToPerm'
+
+-USE_LIBS += [
+- 'crmf',
+-]
+-
+ include('/ipc/chromium/chromium-config.mozbuild')
+
+ if CONFIG['GNU_CXX']:
diff --git a/PKGBUILD b/PKGBUILD
index 76acdda62ac1..1f15f3d72c66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=firefox-esr-gtk2
_pkgname=firefox-esr
-pkgver=52.1.2
+pkgver=52.2.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org, Extended Support Release"
arch=(i686 x86_64)
@@ -26,10 +26,14 @@ replaces=(firefox-gtk2)
options=(!emptydirs !makeflags !strip)
source=(https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz
firefox.desktop firefox-symbolic.svg
+ 0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
+ 0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch
firefox-install-dir.patch fix-wifi-scanner.diff)
-sha256sums=('388e0454d69801f0f2010f8f93b796420ec0493fbf138fc659dbd5b497b8373b'
+sha256sums=('a2f180e4109b15d86d58444134996c1d49eb52e7702d89510508fbd7bddb9381'
'ada313750e6fb14558b37c764409a17c1672a351a46c73b350aa1fe4ea9220ef'
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
+ '413cd6d366d78f325d80ebebccfd0afa0d266b40b2e54b66ba2fa03c15f3ea67'
+ '93c495526c1a1227f76dda5f3a43b433bc7cf217aaf74bd06b8fc187d285f593'
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
@@ -58,6 +62,12 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
patch -Np1 -i ../fix-wifi-scanner.diff
+ # https://bugs.archlinux.org/task/53890
+ patch -Np1 -i ../0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
+
+ # https://bugs.archlinux.org/task/54395 // https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
+ patch -Np1 -i ../0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch
+
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@@ -74,6 +84,7 @@ ac_add_options --enable-default-toolkit=cairo-gtk2
# Branding
ac_add_options --enable-official-branding
ac_add_options --enable-update-channel=release
+ac_add_options --with-distribution-id=org.archlinux
export MOZILLA_OFFICIAL=1
export MOZ_TELEMETRY_REPORTING=1
export MOZ_ADDON_SIGNING=1
@@ -144,6 +155,19 @@ pref("extensions.shownSelectionUI", true);
pref("browser.tabs.remote.autostart", true);
END
+ _distini="$pkgdir/usr/lib/firefox/distribution/distribution.ini"
+ install -Dm644 /dev/stdin "$_distini" <<END
+[Global]
+id=archlinux
+version=1.0
+about=Mozilla Firefox for Arch Linux
+
+[Preferences]
+app.distributor=archlinux
+app.distributor.channel=$pkgname
+app.partner.archlinux=archlinux
+END
+
for i in 16 22 24 32 48 256; do
install -Dm644 browser/branding/official/default$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png"