summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2020-06-28 14:48:36 +0200
committerMuflone2020-06-28 14:50:33 +0200
commit9a84cf19fb4e4fdcc8a01f2482ce8657b7d3fad3 (patch)
tree7c15e43bccde026536aa2a2a9a2b4d24f0d64dcd
parent26af2169d9d13f999573ae3c58f83acae588e2bc (diff)
downloadaur-9a84cf19fb4e4fdcc8a01f2482ce8657b7d3fad3.tar.gz
Updated package firefox-esr52 52.9.0-6
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--gfxFont.patch105
3 files changed, 116 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 832b54916f90..14f24a7aae7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-esr52
pkgdesc = Standalone web browser from mozilla.org, Extended Support Release 52.x with NPAPI support
pkgver = 52.9.0
- pkgrel = 5
+ pkgrel = 6
url = https://www.mozilla.org/en-US/firefox/organizations/
arch = x86_64
license = MPL
@@ -58,6 +58,7 @@ pkgbase = firefox-esr52
source = distribution.ini
source = gcc9_format-overflow.patch
source = glibc-gettid-wrapper.patch
+ source = gfxFont.patch
validpgpkeys = 2B90598A745E992F315E22C58AB132963A06537A
sha256sums = c01d09658c53c1b3a496e353a24dad03b26b81d3b1d099abc26a06f81c199dd6
sha256sums = 9efd02ff78c31f8690a12401faac2605dffcac12eaf11e1791ec4221570c2746
@@ -74,6 +75,7 @@ pkgbase = firefox-esr52
sha256sums = 8ae5b7cd1f7092f13859b632e1e5f69948b2801e0459fdf29c745c89f8eeb823
sha256sums = b66a84af7cc1809fe9dd0d7737f6043be2919ebe0a2c752cca483d67957ad431
sha256sums = e2f6353d2021bb2490acd7216762cd5bae41eb55a82e245813a62a7024c01229
+ sha256sums = ba7858a8cb852388c870bb9acd20bedc5e9cb0b2cf7bdfa5c334e61350279232
pkgname = firefox-esr52
diff --git a/PKGBUILD b/PKGBUILD
index f53520e79bcd..cca88b879e4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=firefox-esr52
pkgver=52.9.0
-pkgrel=5
+pkgrel=6
pkgdesc='Standalone web browser from mozilla.org, Extended Support Release 52.x with NPAPI support'
arch=('x86_64')
license=('MPL' 'GPL' 'LGPL')
@@ -35,7 +35,8 @@ source=("https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefo
"vendor.js"
"distribution.ini"
"gcc9_format-overflow.patch"
- "glibc-gettid-wrapper.patch")
+ "glibc-gettid-wrapper.patch"
+ "gfxFont.patch")
sha256sums=('c01d09658c53c1b3a496e353a24dad03b26b81d3b1d099abc26a06f81c199dd6'
'9efd02ff78c31f8690a12401faac2605dffcac12eaf11e1791ec4221570c2746'
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
@@ -50,7 +51,8 @@ sha256sums=('c01d09658c53c1b3a496e353a24dad03b26b81d3b1d099abc26a06f81c199dd6'
'3c039dbfdcf63022812b51f35289b176b26b4a9933da073f8788fde02be9fdcd'
'8ae5b7cd1f7092f13859b632e1e5f69948b2801e0459fdf29c745c89f8eeb823'
'b66a84af7cc1809fe9dd0d7737f6043be2919ebe0a2c752cca483d67957ad431'
- 'e2f6353d2021bb2490acd7216762cd5bae41eb55a82e245813a62a7024c01229')
+ 'e2f6353d2021bb2490acd7216762cd5bae41eb55a82e245813a62a7024c01229'
+ 'ba7858a8cb852388c870bb9acd20bedc5e9cb0b2cf7bdfa5c334e61350279232')
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -109,6 +111,9 @@ prepare() {
# Fix for gettid() wrapper in newer glibc
# https://bugzilla.mozilla.org/show_bug.cgi?id=1533969
patch -Np1 -i "${srcdir}/glibc-gettid-wrapper.patch"
+
+ # Fix for gfxFont.cpp
+ patch -Np1 -i "${srcdir}/gfxFont.patch"
}
build() {
diff --git a/gfxFont.patch b/gfxFont.patch
new file mode 100644
index 000000000000..609797cf8006
--- /dev/null
+++ b/gfxFont.patch
@@ -0,0 +1,105 @@
+--- firefox-52.9.0esr.orig/gfx/thebes/gfxFont.cpp 2020-06-03 21:55:12.303261510 +0300
++++ firefox-52.9.0esr/gfx/thebes/gfxFont.cpp 2020-06-03 21:57:35.318890953 +0300
+@@ -3071,6 +3071,28 @@
+
+ return true;
+ }
++// Explicit instantiations of GetShapedWord, to avoid libxul link failure
++template gfxShapedWord*
++gfxFont::GetShapedWord(DrawTarget *aDrawTarget,
++ const uint8_t *aText,
++ uint32_t aLength,
++ uint32_t aHash,
++ Script aRunScript,
++ bool aVertical,
++ int32_t aAppUnitsPerDevUnit,
++ uint32_t aFlags,
++ gfxTextPerfMetrics *aTextPerf);
++
++template gfxShapedWord*
++gfxFont::GetShapedWord(DrawTarget *aDrawTarget,
++ const char16_t *aText,
++ uint32_t aLength,
++ uint32_t aHash,
++ Script aRunScript,
++ bool aVertical,
++ int32_t aAppUnitsPerDevUnit,
++ uint32_t aFlags,
++ gfxTextPerfMetrics *aTextPerf);
+
+ // Explicit instantiations of SplitAndInitTextRun, to avoid libxul link failure
+ template bool
+--- firefox-52.9.0esr.orig/gfx/thebes/gfxFont.h 2020-06-03 21:55:12.299928120 +0300
++++ firefox-52.9.0esr/gfx/thebes/gfxFont.h 2020-06-03 21:58:04.522669252 +0300
+@@ -2171,6 +2171,72 @@
+ static double CalcXScale(DrawTarget* aDrawTarget);
+ };
+
++// Explicit declarations of SplitAndInitTextRun, to avoid libxul link failure
++extern template bool
++gfxFont::SplitAndInitTextRun(DrawTarget *aDrawTarget,
++ gfxTextRun *aTextRun,
++ const uint8_t *aString,
++ uint32_t aRunStart,
++ uint32_t aRunLength,
++ Script aRunScript,
++ bool aVertical);
++
++extern template bool
++gfxFont::SplitAndInitTextRun(DrawTarget *aDrawTarget,
++ gfxTextRun *aTextRun,
++ const char16_t *aString,
++ uint32_t aRunStart,
++ uint32_t aRunLength,
++ Script aRunScript,
++ bool aVertical);
++
++// Explicit declarations of GetShapedWord, to avoid libxul link failure
++extern template gfxShapedWord*
++gfxFont::GetShapedWord(DrawTarget *aDrawTarget,
++ const uint8_t *aText,
++ uint32_t aLength,
++ uint32_t aHash,
++ Script aRunScript,
++ bool aVertical,
++ int32_t aAppUnitsPerDevUnit,
++ uint32_t aFlags,
++ gfxTextPerfMetrics *aTextPerf);
++
++extern template gfxShapedWord*
++gfxFont::GetShapedWord(DrawTarget *aDrawTarget,
++ const char16_t *aText,
++ uint32_t aLength,
++ uint32_t aHash,
++ Script aRunScript,
++ bool aVertical,
++ int32_t aAppUnitsPerDevUnit,
++ uint32_t aFlags,
++ gfxTextPerfMetrics *aTextPerf);
++
++// Explicit declarations of InitFakeSmallCapsRun, to avoid libxul link failure
++template<> bool
++gfxFont::InitFakeSmallCapsRun(DrawTarget *aDrawTarget,
++ gfxTextRun *aTextRun,
++ const uint8_t *aText,
++ uint32_t aOffset,
++ uint32_t aLength,
++ uint8_t aMatchType,
++ uint16_t aOrientation,
++ Script aScript,
++ bool aSyntheticLower,
++ bool aSyntheticUpper);
++template<> bool
++gfxFont::InitFakeSmallCapsRun(DrawTarget *aDrawTarget,
++ gfxTextRun *aTextRun,
++ const char16_t *aText,
++ uint32_t aOffset,
++ uint32_t aLength,
++ uint8_t aMatchType,
++ uint16_t aOrientation,
++ Script aScript,
++ bool aSyntheticLower,
++ bool aSyntheticUpper);
++
+ // proportion of ascent used for x-height, if unable to read value from font
+ #define DEFAULT_XHEIGHT_FACTOR 0.56f \ No newline at end of file