summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2015-12-14 11:27:57 +0100
committerHyacinthe Cartiaux2015-12-14 11:27:57 +0100
commitb3b6c5892c38dd187153432f7776e6dde82ec64d (patch)
tree5b423a136f20c64527c8fe1d56f8a4d9357d20ec
parente85bd62b22cec1f7e349207f855b9a90daa32e9d (diff)
downloadaur-b3b6c5892c38dd187153432f7776e6dde82ec64d.tar.gz
Pkgrel bump: do not unzip the xpi
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7b3be7fcaf0..6277358f8e0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
-# Generated by mksrcinfo v7
-# Thu Oct 15 16:15:42 UTC 2015
+# Generated by mksrcinfo v8
+# Mon Dec 14 10:27:36 UTC 2015
pkgbase = firefox-extension-addonbar
pkgdesc = Gives you a place to put all your add-on buttons without over-crowding the navigation bar.
pkgver = 3.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://addons.mozilla.org/en-US/firefox/addon/the-addon-bar/
arch = any
license = MIT
depends = firefox
- source = https://addons.cdn.mozilla.net/storage/public-staging/473193/the_addon_bar_restored-3.2-fx.xpi
- md5sums = 237a158e104406c04e3bfd600176898b
+ source = https://addons.cdn.mozilla.net/user-media/addons/473193/the_addon_bar_restored-3.2-fx.xpi
+ sha256sums = 3d555211790a440c6b6757984dc98637523d9bbe03578e67f3ae7756a17c5054
pkgname = firefox-extension-addonbar
diff --git a/PKGBUILD b/PKGBUILD
index 3df37a2bf4a2..dca205cb48c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,20 @@ _plugin_name=addonbar
_plugin_version=3.2.1
pkgname=firefox-extension-$_plugin_name
pkgver=$_plugin_version
-pkgrel=1
+pkgrel=2
pkgdesc="Gives you a place to put all your add-on buttons without over-crowding the navigation bar."
license=('MIT')
arch=('any')
url="https://addons.mozilla.org/en-US/firefox/addon/the-addon-bar/"
depends=("firefox")
-source=("https://addons.cdn.mozilla.net/storage/public-staging/473193/the_addon_bar_restored-3.2-fx.xpi")
-md5sums=('237a158e104406c04e3bfd600176898b')
+source=('https://addons.cdn.mozilla.net/user-media/addons/473193/the_addon_bar_restored-3.2-fx.xpi')
+sha256sums=('3d555211790a440c6b6757984dc98637523d9bbe03578e67f3ae7756a17c5054')
package() {
cd $srcdir
- emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
-
- local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
- install -d $dstdir
- cp -dpr --no-preserve=ownership * $dstdir
- rm $dstdir/the_addon_bar_restored-3.2-fx.xpi
- chmod -R 755 $dstdir
+ local _emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+ test ! -z "${_emid}"
+ local _file=(*.xpi)
+ test "${#_file[@]}" -eq 1
+ install -Dpm644 "${_file}" "${pkgdir}/usr/lib/firefox/browser/extensions/${_emid}.xpi"
}