summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2014-05-09 11:24:44 +0200
committerHyacinthe Cartiaux2015-06-09 00:17:10 +0200
commitc5d1071c0f86e35f63b54d1fcdeca21d197f7974 (patch)
tree758fc9ffbc78903b28776ffeaa71c72a99b136ce
downloadaur-c5d1071c0f86e35f63b54d1fcdeca21d197f7974.tar.gz
[firefox-extension-addonbar] New package (restore the addon bar for firefox 29)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e93aad438f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = firefox-extension-addonbar
+ pkgdesc = Gives you a place to put all your add-on buttons without over-crowding the navigation bar.
+ pkgver = 3.2
+ pkgrel = 1
+ url = https://addons.mozilla.org/en-US/firefox/addon/the-addon-bar/
+ arch = any
+ license = MIT
+ depends = firefox
+ source = https://addons.cdn.mozilla.net/storage/public-staging/473193/the_addon_bar_restored-3.2-fx.xpi
+ md5sums = 237a158e104406c04e3bfd600176898b
+
+pkgname = firefox-extension-addonbar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb6a8614319e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+_plugin_name=addonbar
+_plugin_version=3.2
+pkgname=firefox-extension-$_plugin_name
+pkgver=$_plugin_version
+pkgrel=1
+pkgdesc="Gives you a place to put all your add-on buttons without over-crowding the navigation bar."
+license=('MIT')
+arch=('any')
+url="https://addons.mozilla.org/en-US/firefox/addon/the-addon-bar/"
+depends=("firefox")
+source=("https://addons.cdn.mozilla.net/storage/public-staging/473193/the_addon_bar_restored-3.2-fx.xpi")
+md5sums=('237a158e104406c04e3bfd600176898b')
+
+package() {
+ cd $srcdir
+ emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+
+ local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
+ install -d $dstdir
+ cp -dpr --no-preserve=ownership * $dstdir
+ rm $dstdir/the_addon_bar_restored-3.2-fx.xpi
+ chmod -R 755 $dstdir
+}