summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:39:34 +0100
committerXZS2016-10-31 18:39:34 +0100
commit18d0af4aedbec9e39328fc056c745ef618325632 (patch)
tree89b724495e14527ae84ea5494f53aa95c13e26da
parentdfdf2a838f985c0bb03f18d04a2e7b67df320f5d (diff)
downloadaur-18d0af4aedbec9e39328fc056c745ef618325632.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f66b8afaf9e4..58f6fe34ee11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-extension-beyond-australis-git
pkgdesc = A Firefox add-on to improve the feeling of using the new Australis theme.
pkgver = 1.4.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Quicksaver/The-Fox--Only-Better
arch = any
license = MPLv2
diff --git a/PKGBUILD b/PKGBUILD
index a1110306b0f9..da0e34d60678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-extension-beyond-australis-git
pkgver=1.4.6
-pkgrel=1
+pkgrel=2
pkgdesc='A Firefox add-on to improve the feeling of using the new Australis theme.'
url='https://github.com/Quicksaver/The-Fox--Only-Better'
arch=('any')
@@ -45,9 +45,18 @@ pkgver() {
echo -n .
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {