summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHezekiah Michael2020-03-04 16:50:00 -0500
committerHezekiah Michael2020-03-04 16:50:00 -0500
commite0eb18700b7fd4da2a8169db716e0a7420599de8 (patch)
treed7aac79a741bdb11e1ac5e50fe7060b639444fa6
downloadaur-e0eb18700b7fd4da2a8169db716e0a7420599de8.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..198e4c565e68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = firefox-extension-bypass-paywalls
+ pkgdesc = Browser plugin to bypass paywalls on many news sites.
+ pkgver = 1.6.6
+ pkgrel = 1
+ url = https://github.com/iamadamdev/bypass-paywalls-firefox/
+ arch = any
+ license = MIT
+ depends = firefox
+ optdepends = firefox-ublock-origin
+ noextract = ${_plugin_name}-${pkgver}${_plugin_ext}.xpi
+ source = https://github.com/iamadamdev/bypass-paywalls-firefox/releases/download/v1.6.6/bypass_paywalls-1.6.6-an+fx.xpi
+ sha256sums = 100f44a9406799c97cf09baeb8862152e73d1e78717a5823555609b51a0bdeb4
+
+pkgname = firefox-extension-bypass-paywalls
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..50e75f018c05
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.xpi
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba655b7b46a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Hezekiah Michael <spiritomb@protonmail.com>
+
+_plugin_name=bypass_paywalls
+_plugin_version=1.6.6
+_plugin_ext="-an+fx"
+pkgdesc="Browser plugin to bypass paywalls on many news sites."
+license=('MIT')
+
+pkgname=firefox-extension-bypass-paywalls
+pkgver=$_plugin_version
+pkgrel=1
+arch=('any')
+url="https://github.com/iamadamdev/bypass-paywalls-firefox/"
+depends=("firefox")
+optdepends=("firefox-ublock-origin")
+source=("https://github.com/iamadamdev/bypass-paywalls-firefox/releases/download/v${pkgver}/${_plugin_name}-${pkgver}${_plugin_ext}.xpi")
+noextract=('${_plugin_name}-${pkgver}${_plugin_ext}.xpi')
+
+package() {
+ cd "${srcdir}"
+ _extension_id="bypasspaywalls@bypasspaywalls.weebly.com"
+ _extension_dest="${pkgdir}/usr/lib/firefox/browser/extensions/${_extension_id}"
+ install -Dm644 ${_plugin_name}-${pkgver}${_plugin_ext}.xpi "${_extension_dest}.xpi"
+}
+sha256sums=('100f44a9406799c97cf09baeb8862152e73d1e78717a5823555609b51a0bdeb4')