summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbertaga2020-06-10 15:02:21 +0200
committerbertaga2020-06-10 15:02:21 +0200
commit71008e90e9f2b811fa6454c3a9c5ff9fdf69c4b0 (patch)
tree32329f57345f6969b94e9f4dcce78683efbc6894
downloadaur-71008e90e9f2b811fa6454c3a9c5ff9fdf69c4b0.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32efa6cf02aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = firefox-extension-cookie-autodelete
+ pkgdesc = Firefox extension that automatically deletes cookies.
+ pkgver = 3.3.1
+ pkgrel = 1
+ url = https://github.com/Cookie-AutoDelete/Cookie-AutoDelete
+ arch = any
+ groups = firefox-addons
+ license = MIT
+ depends = firefox
+ noextract = firefox-extension-cookie-autodelete-3.3.1.xpi
+ source = firefox-extension-cookie-autodelete-3.3.1.xpi::https://github.com/Cookie-AutoDelete/Cookie-AutoDelete/releases/download/v3.3.1/Cookie-AutoDelete_v3.3.1_Firefox.xpi
+ b2sums = 4a9108a0cb9ca21e100b7205f9fce1a0fb9109a56ed07b11132a6f0c60893191f589f31fd44120bb72b9d90b8c705e8169a1a4d005dbb0d4a9f4bfff7b529101
+
+pkgname = firefox-extension-cookie-autodelete
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d0ca0165117
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Franck Stauffer <franck.stauffer@telecom-sudparis.eu>
+
+pkgname='firefox-extension-cookie-autodelete'
+pkgver=3.3.1
+pkgrel=1
+pkgdesc="Firefox extension that automatically deletes cookies."
+license=('MIT')
+arch=('any')
+url="https://github.com/Cookie-AutoDelete/Cookie-AutoDelete"
+depends=('firefox')
+groups=('firefox-addons')
+source=("$pkgname-$pkgver.xpi::https://github.com/Cookie-AutoDelete/Cookie-AutoDelete/releases/download/v${pkgver}/Cookie-AutoDelete_v${pkgver}_Firefox.xpi")
+noextract=("$pkgname-$pkgver.xpi")
+b2sums=('4a9108a0cb9ca21e100b7205f9fce1a0fb9109a56ed07b11132a6f0c60893191f589f31fd44120bb72b9d90b8c705e8169a1a4d005dbb0d4a9f4bfff7b529101')
+
+package() {
+ install -Dm644 "$pkgname-$pkgver.xpi" "$pkgdir/usr/lib/firefox/browser/extensions/CookieAutoDelete@kennydo.com.xpi"
+}