summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgS6442015-06-09 00:10:18 +0200
committergS6442015-06-09 00:10:18 +0200
commite608056e60d23f7e93d5991f14c743515e15c275 (patch)
treedec2072a2535e206635eaf5cd1a74af66bba0117
downloadaur-e608056e60d23f7e93d5991f14c743515e15c275.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1a4be263e39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = firefox-extension-downthemall
+ pkgdesc = A Download Manager extension for Firefox with advanced capabilities
+ pkgver = 2.0.18
+ pkgrel = 2
+ url = http://www.downthemall.net/
+ arch = any
+ license = GPL2
+ depends = firefox
+ source = https://addons.cdn.mozilla.net/user-media/addons/201/downthemall-2.0.18-sm+fx.xpi
+ md5sums = 7d7b014579db7b90e0cd356ef9c18eef
+
+pkgname = firefox-extension-downthemall
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e887a5708f70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sebastian Lau <lauseb644@gmail.com>
+# Contributor: Tianjiao Yin <ytj000+aur@gmail.com>
+
+pkgname=firefox-extension-downthemall
+pkgver=2.0.18
+pkgrel=2
+pkgdesc="A Download Manager extension for Firefox with advanced capabilities"
+arch=('any')
+url="http://www.downthemall.net/"
+license=('GPL2')
+depends=('firefox')
+# source=("https://code.downthemall.net/releases/downthemall-$pkgver.xpi")
+# md5sums=("$(curl -sL ${source/.xpi/.md5} | cut -d ' ' -f1)")
+source=("https://addons.cdn.mozilla.net/user-media/addons/201/downthemall-${pkgver}-sm+fx.xpi")
+md5sums=('7d7b014579db7b90e0cd356ef9c18eef')
+
+package() {
+ # Variables
+ emid=$(grep -Po 'id>\K[^<]*' install.rdf | head -1)
+ dstdir="$pkgdir/usr/lib/firefox/browser/extensions/$emid/"
+
+ # Install
+ install -d "$dstdir"
+ rm *.xpi
+ mv * "$dstdir"
+}