summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHezekiah Michael2020-02-27 14:11:35 -0500
committerHezekiah Michael2020-02-27 14:11:35 -0500
commite0593173bf19c64553680653ac5372c08a89b414 (patch)
treedf34b4bb39392efb4f02605d63d377b4a8bee01f
downloadaur-e0593173bf19c64553680653ac5372c08a89b414.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c7195eaa2ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = firefox-extension-facebook-container
+ pkgdesc = Browser plugin to containerize Facebook and its affiliates.
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://addons.mozilla.org/en-US/firefox/addon/facebook-container/
+ arch = any
+ license = MPL
+ depends = firefox>=52
+ optdepends = firefox-extension-multi-account-containers
+ noextract = ${_plugin_name}-${pkgver}${_plugin_ext}.xpi
+ source = https://addons.mozilla.org/firefox/downloads/file/3414682/facebook_container-2.0.3-fx.xpi
+ sha256sums = 26d4b0541484ffc7364b8e429500a28bd71b9676bb92934e394661a5afcf160b
+
+pkgname = firefox-extension-facebook-container
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..50e75f018c05
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.xpi
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01f7bd7670a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Hezekiah Michael <spiritomb@protonmail.com>
+
+_plugin_name=facebook_container
+_plugin_version=2.0.3
+_plugin_id=3414682
+_plugin_ext="-fx"
+pkgdesc="Browser plugin to containerize Facebook and its affiliates."
+license=('MPL')
+
+pkgname=firefox-extension-facebook-container
+pkgver=$_plugin_version
+pkgrel=1
+arch=('any')
+url="https://addons.mozilla.org/en-US/firefox/addon/facebook-container/"
+depends=("firefox>=52")
+optdepends=("firefox-extension-multi-account-containers")
+source=("https://addons.mozilla.org/firefox/downloads/file/${_plugin_id}/${_plugin_name}-${pkgver}${_plugin_ext}.xpi")
+noextract=('${_plugin_name}-${pkgver}${_plugin_ext}.xpi')
+
+package() {
+ cd "${srcdir}"
+ _extension_id="@contain-facebook"
+ _extension_dest="${pkgdir}/usr/lib/firefox/browser/extensions/${_extension_id}"
+ install -Dm644 ${_plugin_name}-${pkgver}${_plugin_ext}.xpi "${_extension_dest}.xpi"
+}
+sha256sums=('26d4b0541484ffc7364b8e429500a28bd71b9676bb92934e394661a5afcf160b')