summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-20 18:41:35 +0200
committerXZS2016-04-20 18:41:35 +0200
commit55d55e5be09a0dae060686d7cda7b9409caf4872 (patch)
treec856f9296c6a25d914d131717d6fddc27ecb96ba
parent1b5609950e44e4a7158267e3acc494f52d56befd (diff)
downloadaur-55d55e5be09a0dae060686d7cda7b9409caf4872.tar.gz
omit hidden files
Hidden files are normally only used to manage the source code of the extension. They are not needed in and have no direct relation to the compiled package and can thus be left out safely. At this moment, there are no hidden files in this extension. So this change happens just in anticipation to future additions and not raising the need to increment the pkgrel.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e00ac8407cb..82a7e47c54b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -76,7 +76,8 @@ depends=(${pkgname%%-*})
package() {
compose_dependencies
prepare_target
- cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ install -d "$destdir/$id"
+ cp --no-preserve=ownership,mode -r * "$destdir/$id"
}
# Hidden from mksrcinfo in silly subfunction.