summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:39:18 +0100
committerXZS2016-10-31 18:39:18 +0100
commit77caee32d381d0c3c832985f6dbb11c2580bcf3d (patch)
tree7e0b7d3e3996f91b19564d28f990267d6a7442d3
parent1467272704c31896de9e74f70ebd676be4bd6c3f (diff)
downloadaur-77caee32d381d0c3c832985f6dbb11c2580bcf3d.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b2b5bbc0556..9b7ab198e69d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-extension-flash-video-downloader
pkgdesc = download your favorite videos in 1 click
pkgver = 13.2.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.flashvideodownloader.org/
arch = any
license = MPLv1.1
diff --git a/PKGBUILD b/PKGBUILD
index 55073123fdbc..14cbc1f73e0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-extension-flash-video-downloader
pkgver=13.2.4
-pkgrel=1
+pkgrel=2
pkgdesc='download your favorite videos in 1 click'
url='http://www.flashvideodownloader.org/'
license=('MPLv1.1')
@@ -42,9 +42,18 @@ query-version() {
xmllint .version --xpath \
"//application[appID='$2']/$1_version/text()"
}
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {