summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-22 11:41:11 +0200
committerXZS2016-04-22 11:41:11 +0200
commit783974060974518b0ec9f1edcc69a01a2200c68b (patch)
tree6614ca5ccee1295ace650e1fc3b1ccbcdb7ae36a
parent55d55e5be09a0dae060686d7cda7b9409caf4872 (diff)
downloadaur-783974060974518b0ec9f1edcc69a01a2200c68b.tar.gz
exclude hidden filed in subdirectories
Despite the wild card * not coping hidden files, this does not exclude such in subdirectories. A reliable method to exclude files by a pattern like "starting with a dot" would be rsync. But to not pull it in as an additional dependency, copy and find are preferred.
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82a7e47c54b7..013c183940fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -76,8 +76,8 @@ depends=(${pkgname%%-*})
package() {
compose_dependencies
prepare_target
- install -d "$destdir/$id"
- cp --no-preserve=ownership,mode -r * "$destdir/$id"
+ cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ find "$destdir/$id" -mindepth 1 -name ".*" -exec rm -rf '{}' +
}
# Hidden from mksrcinfo in silly subfunction.