summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-23 01:22:51 +0200
committerXZS2016-04-23 01:22:51 +0200
commitfaf7c3d202082d68b44fac1eb2f642e0cecb35e2 (patch)
tree0862df1f20ce2ffdd445c8be33ef16760b1a0123
parent783974060974518b0ec9f1edcc69a01a2200c68b (diff)
downloadaur-faf7c3d202082d68b44fac1eb2f642e0cecb35e2.tar.gz
preserve META-INF
Because of a bug in libarchive, extracting the XPI archive through makepkg's automated process leaves the contents of the META-INF directory scrambled. This causes Firefox to reject the activation of the Add-On as long as "xpinstall.signatures.required" is not set to to "false" in "about:config". Unzip preserves the content flawlessly. The underlying bug in libarchive [1] is already fixed, but the changes are not yet shipped out through a release. An Arch Linux bug [2] also tracks the case. This commit shall be reverted as soon as the latter is marked as resolved. [1]: https://github.com/libarchive/libarchive/commit/5422a51ff294c58173338073ea400e71935350bb [2]: https://bugs.archlinux.org/task/41071
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a443dc428f83..3061c25b28c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = firefox-extension-flash-video-downloader
pkgdesc = download your favorite videos in 1 click
pkgver = 11.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.flashvideodownloader.org/
arch = any
license = MPLv1.1
+ makedepends = unzip
makedepends = rasqal
depends = firefox
+ noextract = firefox-extension-flash-video-downloader.zip
source = firefox-extension-flash-video-downloader.zip::https://addons.mozilla.org/firefox/downloads/latest/flash-video-downloader/platform:2/
source = version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/flash-video-downloader
md5sums = bae77fbd0d6fe5c839ef266f69dd87bc
diff --git a/PKGBUILD b/PKGBUILD
index 013c183940fd..c687ef42ee4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-extension-flash-video-downloader
pkgver=11.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='download your favorite videos in 1 click'
url='http://www.flashvideodownloader.org/'
license=('MPLv1.1')
@@ -17,8 +17,11 @@ source+=(
"version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/${pkgname#*-*-}"
)
md5sums+=('SKIP')
+noextract+=("${pkgname}.zip")
+makedepends+=(unzip)
prepare() {
+ unzip "${pkgname}.zip"
rm ${pkgname}.zip
}