summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2015-11-30 11:07:01 +0100
committerHyacinthe Cartiaux2015-11-30 11:07:01 +0100
commitc984e82b7354e9c067666e94f2a465efcfdc146b (patch)
tree55f32f0f8c899740b8325ebcf026cd1245806ab5
parenta1717dd5cc7f41b90e6f0649d934ee608737f2a7 (diff)
downloadaur-c984e82b7354e9c067666e94f2a465efcfdc146b.tar.gz
Pkgrel bump: compatibility with the new extension signing mechanism
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 180393ae3a40..7888e409aab3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,19 @@ license=('GPL')
pkgname=firefox-extension-$_plugin_name
pkgver=$_plugin_version
-pkgrel=1
+pkgrel=2
arch=('any')
url="https://addons.mozilla.org/firefox/addon/$_plugin_id"
depends=("firefox")
source=("https://addons.cdn.mozilla.net/user-media/addons/2464/foxyproxy_standard-${pkgver}-sm+tb+fx.xpi")
+sha256sums=('56dc7075233db41e4d50304762e8f7518b8ebd6c65eeefc9cb72699e290bf749')
package() {
cd $srcdir
- emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
- local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
- install -d $dstdir
- #sed -i 's#<em:maxVersion>.*</em:maxVersion>#<em:maxVersion>11.*</em:maxVersion>#' install.rdf
- rm *.xpi
- mv * $dstdir
+ local _emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+ test ! -z "${_emid}"
+ local _file=(*.xpi)
+ test "${#_file[@]}" -eq 1
+ install -Dpm644 "${_file}" "${pkgdir}/usr/lib/firefox/browser/extensions/${_emid}.xpi"
}
-sha256sums=('56dc7075233db41e4d50304762e8f7518b8ebd6c65eeefc9cb72699e290bf749')
-