summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmeGa2016-02-24 14:04:46 -0600
committerOmeGa2016-02-24 14:04:46 -0600
commit9cde6072ad9e9047f612fd4c29965e2d5fd2c047 (patch)
tree6c51c9cad9ff08db71fe6edbcd9779e78047e61e
parent972490fca257d90ae1bc8bfec0ac396729e4fff2 (diff)
downloadaur-9cde6072ad9e9047f612fd4c29965e2d5fd2c047.tar.gz
Update to 3.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f80c1866268..72c7c7a2d7a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Feb 24 20:04:42 UTC 2016
pkgbase = firefox-extension-greasemonkey
pkgdesc = Customize the way a web page displays or behaves, by using small bits of JavaScript.
- pkgver = 3.6
+ pkgver = 3.7
pkgrel = 1
url = http://www.greasespot.net/
arch = any
license = MPL
- depends = firefox>=35.0
- source = https://addons.mozilla.org/firefox/downloads/file/370452/greasemonkey-3.6.xpi
- sha1sums = 35b76e5cc77087ac1fc6b0400fc4d0ae57eb57d5
+ depends = firefox>=38.0
+ source = https://addons.mozilla.org/firefox/downloads/file/402242/greasemonkey-3.7.xpi
+ sha1sums = d1a43b10e9ffadaf95d0558bb57dd467758e6de2
pkgname = firefox-extension-greasemonkey
diff --git a/PKGBUILD b/PKGBUILD
index 721a7f015ec6..ca60eea472ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,24 @@
# Contributor: Vinycius Maia <suportevg@uol.com.br>
pkgname=firefox-extension-greasemonkey
-_file=370452
-pkgver=3.6
+_file=402242
+pkgver=3.7
pkgrel=1
pkgdesc="Customize the way a web page displays or behaves, by using small bits of JavaScript."
arch=('any')
url="http://www.greasespot.net/"
license=('MPL')
-depends=('firefox>=35.0')
+depends=('firefox>=38.0')
source=(https://addons.mozilla.org/firefox/downloads/file/$_file/greasemonkey-$pkgver.xpi)
-sha1sums=('35b76e5cc77087ac1fc6b0400fc4d0ae57eb57d5')
+sha1sums=('d1a43b10e9ffadaf95d0558bb57dd467758e6de2')
package() {
- cd "$srcdir"
- local emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)
- local dstdir="$pkgdir/usr/lib/firefox/browser/extensions/$emid"
- find . -type f -exec install -Dm644 '{}' "$dstdir/{}" \;
+ cd $srcdir
+ local _emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+ test ! -z "${_emid}"
+ local _file=(*.xpi)
+ test "${#_file[@]}" -eq 1
+ install -Dpm644 "${_file}" "${pkgdir}/usr/lib/firefox/browser/extensions/${_emid}.xpi"
}
# vim:set ts=2 sw=2 et: