summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-23 01:22:55 +0200
committerXZS2016-04-23 01:22:55 +0200
commit0a84449b0ece19394df12ed6b81d8344cde46ca6 (patch)
tree3bd1d4676f0276b46373039289ee595c5a639467
parent9d0d1b3647e8b6d2a3068a033131495121d335e4 (diff)
downloadaur-0a84449b0ece19394df12ed6b81d8344cde46ca6.tar.gz
preserve META-INF
Because of a bug in libarchive, extracting the XPI archive through makepkg's automated process leaves the contents of the META-INF directory scrambled. This causes Firefox to reject the activation of the Add-On as long as "xpinstall.signatures.required" is not set to to "false" in "about:config". Unzip preserves the content flawlessly. The underlying bug in libarchive [1] is already fixed, but the changes are not yet shipped out through a release. An Arch Linux bug [2] also tracks the case. This commit shall be reverted as soon as the latter is marked as resolved. [1]: https://github.com/libarchive/libarchive/commit/5422a51ff294c58173338073ea400e71935350bb [2]: https://bugs.archlinux.org/task/41071
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cabb68b8e3c..ad635c283c69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = firefox-extension-hide-tab-bar-with-one-tab
pkgdesc = Hide the tab bar if there is only one tab.
pkgver = 1.5.1.signed
- pkgrel = 1
+ pkgrel = 2
url = http://forums.mozillazine.org/viewtopic.php?f=48&t=2141579
arch = any
license = MPLv2
+ makedepends = unzip
makedepends = rasqal
depends = firefox
+ noextract = firefox-extension-hide-tab-bar-with-one-tab.zip
source = firefox-extension-hide-tab-bar-with-one-tab.zip::https://addons.mozilla.org/firefox/downloads/latest/hide-tab-bar-with-one-tab/platform:2/
source = version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/hide-tab-bar-with-one-tab
md5sums = 0177f69d998d66a9f181b5744bee21a1
diff --git a/PKGBUILD b/PKGBUILD
index 41809959190b..1219cbd9f9ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-extension-hide-tab-bar-with-one-tab
pkgver=1.5.1.signed
-pkgrel=1
+pkgrel=2
pkgdesc='Hide the tab bar if there is only one tab.'
url='http://forums.mozillazine.org/viewtopic.php?f=48&t=2141579'
license=('MPLv2')
@@ -17,8 +17,11 @@ source+=(
"version::https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/${pkgname#*-*-}"
)
md5sums+=('SKIP')
+noextract+=("${pkgname}.zip")
+makedepends+=(unzip)
prepare() {
+ unzip "${pkgname}.zip"
rm ${pkgname}.zip
}