summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-20 18:41:30 +0200
committerXZS2016-04-20 18:41:30 +0200
commit14b98fa7afe04f4e688576709fed1fe18d0d6d67 (patch)
tree7dd3a524110ea90a1b925cf1a25fef0cbaa207f1
parent0b25a5242d5ddbde02e8924d2649bd20debb8e97 (diff)
downloadaur-14b98fa7afe04f4e688576709fed1fe18d0d6d67.tar.gz
omit hidden files
Hidden files are normally only used to manage the source code of the extension. They are not needed in and have no direct relation to the compiled package and can thus be left out safely. At this moment, there are no hidden files in this extension. So this change happens just in anticipation to future additions and not raising the need to increment the pkgrel.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0d787d0e34d..4563f4371a85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -76,7 +76,8 @@ depends=(${pkgname%%-*})
package() {
compose_dependencies
prepare_target
- cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ install -d "$destdir/$id"
+ cp --no-preserve=ownership,mode -r * "$destdir/$id"
}
# Hidden from mksrcinfo in silly subfunction.