summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:39:10 +0100
committerXZS2016-10-31 18:39:10 +0100
commit56904fbaf335a2bc80a32c6683d1d441dbdacdc8 (patch)
treecea800778f3a22ab0d00b53df603f1253c1a5a0d
parent349a8888e07d14f5b811639ed8e20b83f9a2304b (diff)
downloadaur-56904fbaf335a2bc80a32c6683d1d441dbdacdc8.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43779489a7fb..13b9b73d1818 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-extension-hide-tab-bar-with-one-tab
pkgdesc = Hide the tab bar if there is only one tab.
pkgver = 1.5.1.signed.1.signed
- pkgrel = 1
+ pkgrel = 2
url = http://forums.mozillazine.org/viewtopic.php?f=48&t=2141579
arch = any
license = MPLv2
diff --git a/PKGBUILD b/PKGBUILD
index 9a787e27e52e..982554dcd265 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-extension-hide-tab-bar-with-one-tab
pkgver=1.5.1.signed.1.signed
-pkgrel=1
+pkgrel=2
pkgdesc='Hide the tab bar if there is only one tab.'
url='http://forums.mozillazine.org/viewtopic.php?f=48&t=2141579'
license=('MPLv2')
@@ -42,9 +42,18 @@ query-version() {
xmllint .version --xpath \
"//application[appID='$2']/$1_version/text()"
}
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {