summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Milette2017-06-09 08:53:39 -0400
committerCharles Milette2017-06-09 08:53:39 -0400
commit80a70d23673b954d9d0629fd9b3720ff70427e62 (patch)
tree78fc55aa40851d8f822c1570ecf2f3f593c1308b
parent8f371af4a2fb2f3902dd51056965593fadf8545a (diff)
downloadaur-80a70d23673b954d9d0629fd9b3720ff70427e62.tar.gz
Revive package using AMO source
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 15 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afa0305068a9..5f00fb85153b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = firefox-extension-htitle
- pkgdesc = Hide Firefox title bar if window is maximized (Useful in GNOME Shell)
+ pkgdesc = Hide title bar if window is maximized - Addon is discontinued but still works as intended
pkgver = 3.4
pkgrel = 1
url = https://github.com/seleznev/firefox-extension-htitle
arch = any
- license = MPLv2
- makedepends = unzip
- depends = firefox
- source = https://github.com/seleznev/firefox-extension-htitle/releases/download/v3.4/firefox-extension-htitle-3.4.xpi
- md5sums = d1ff5eb802d5ff7bd89f5c20892752b9
+ license = MPL
+ noextract = htitle-3.4-sm+tb+fx-linux.xpi
+ source = https://addons.cdn.mozilla.net/user-media/addons/386325/htitle-3.4-sm+tb+fx-linux.xpi
+ sha512sums = 41be1e743fe06dc3cc10935455ca6d65548c9a29e982206fa767d9a0608e85fe04f8b11437e9ee8501a9e3d6f2ab90f4111d6c84277a1f2d04dd00cdc25b34a0
pkgname = firefox-extension-htitle
diff --git a/PKGBUILD b/PKGBUILD
index 053c35ed88dc..039319c039f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,18 @@
-# Contributor: Lex Black <autumn-wind at web dot de>
-# Contributor: Jerome Barnett <techryda at silentdome dot com>
+# Maintainer: Charles Milette <charles.milette@gmail.com>
pkgname=firefox-extension-htitle
pkgver=3.4
pkgrel=1
-pkgdesc="Hide Firefox title bar if window is maximized (Useful in GNOME Shell)"
-url="https://github.com/seleznev/firefox-extension-htitle"
+pkgdesc='Hide title bar if window is maximized - Addon is discontinued but still works as intended'
+url=https://github.com/seleznev/firefox-extension-htitle
arch=('any')
-license=('MPLv2')
-depends=("firefox")
-makedepends=('unzip')
-source=("https://github.com/seleznev/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.xpi")
-md5sums=('d1ff5eb802d5ff7bd89f5c20892752b9')
+license=('MPL')
+source=("https://addons.cdn.mozilla.net/user-media/addons/386325/htitle-$pkgver-sm+tb+fx-linux.xpi")
+noextract=("${source##*/}")
+sha512sums=('41be1e743fe06dc3cc10935455ca6d65548c9a29e982206fa767d9a0608e85fe04f8b11437e9ee8501a9e3d6f2ab90f4111d6c84277a1f2d04dd00cdc25b34a0')
package() {
- local emid=$(sed -n -e '/<\?em:id>\?/!d; s/.*\([\"{].*[}\"]\).*/\1/; s/\"//g; p; q' install.rdf)
- local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
- install -d $dstdir
- # sed -i 's#<em:maxVersion>.*</em:maxVersion>#<em:maxVersion>20.*</em:maxVersion>#' install.rdf
- cp -R * $dstdir
- rm $dstdir/*.xpi
+ install -Dm644 "${source##*/}" "$pkgdir"/usr/lib/firefox/browser/extensions/{c6448328-31f7-4b12-a2e0-5c39d0290307}.xpi
}
+
+# vim:set ts=2 sw=2 et: