summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Korpel2015-08-19 00:21:22 +0200
committerMarcel Korpel2015-08-19 00:21:22 +0200
commite056c41b1e0e7080fb867ef6f134f152186189c2 (patch)
tree512f03b7b4ca72b4e8724750c3da5959ce4dfb3d
downloadaur-e056c41b1e0e7080fb867ef6f134f152186189c2.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03cd1d6ce89c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = firefox-extension-keefox
+ pkgdesc = Adds free, secure and easy to use password management features to Firefox
+ pkgver = 1.4.8.1_signed
+ pkgrel = 1
+ url = http://keefox.org
+ arch = any
+ license = GPL2
+ depends = firefox
+ depends = keepass
+ source = https://addons.mozilla.org/firefox/downloads/latest/306880/platform:2/addon-306880-latest.xpi
+ sha256sums = f5e058bc45a6e6fb419d24eb09a58b571bb8d1b33504707fa467d2ffeb695235
+
+pkgname = firefox-extension-keefox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbaf74c56058
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Marcel Korpel <marcel[dot]korpel[at]gmail>
+
+_plugin_name=keefox
+pkgname=firefox-extension-$_plugin_name
+pkgver=1.4.8.1_signed
+pkgrel=1
+pkgdesc="Adds free, secure and easy to use password management features to Firefox"
+arch=('any')
+url="http://keefox.org"
+license=('GPL2')
+depends=('firefox' 'keepass')
+source=("https://addons.mozilla.org/firefox/downloads/latest/306880/platform:2/addon-306880-latest.xpi")
+sha256sums=('f5e058bc45a6e6fb419d24eb09a58b571bb8d1b33504707fa467d2ffeb695235')
+
+package() {
+ emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)
+ local dstdir="$pkgdir/usr/lib/firefox/browser/extensions/${emid}"
+ install -d "$dstdir"
+ cp -dpr --no-preserve=ownership * "$dstdir"
+ rm "$dstdir/addon-306880-latest.xpi"
+ chmod 644 "$dstdir"/META-INF/*
+}