summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2016-05-29 07:39:59 +0200
committerFadeMind2016-05-29 07:39:59 +0200
commit4387ee03b3600914349436381b03f0ab9d3a92a2 (patch)
treee17e5c2abc049ed771586d7e5d4e6783cd4b98c9
parent8215f8e5c276eb3b3b4451286b7c7639e9409bad (diff)
downloadaur-4387ee03b3600914349436381b03f0ab9d3a92a2.tar.gz
update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 28 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c742ae0d2dda..5b43e274a717 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,17 @@
# Generated by mksrcinfo v8
-# Mon Apr 11 10:14:03 UTC 2016
+# Sun May 29 05:39:59 UTC 2016
pkgbase = firefox-extension-kwallet
pkgdesc = An extension to allows Firefox to use KDE's Kwallet to store passwords
pkgver = 2.4.1
pkgrel = 2
- url = https://addons.mozilla.org/firefox/addon/kde-wallet-password-integratio/
- arch = i686
- arch = x86_64
- license = MPL 1.1
- license = GPL 2.0
- license = LGPL 2.1
+ url = https://addons.mozilla.org/firefox/addon/kwallet/
+ arch = any
+ license = MPL2
makedepends = unzip
- depends = qt4
depends = firefox
- depends = kwalletmanager
- noextract = kde_wallet_password_integration-2.4-fx+tb-linux.xpi
- source = kde_wallet_password_integration-2.4-fx+tb-linux.xpi::https://addons.cdn.mozilla.net/user-media/addons/49357/kde_wallet_password_integration-2.4-fx+tb-linux.xpi
- sha256sums = b424fa047c608763773dbc9ee77e960df35c8200ac3b7dfa335b476dc5d13fd3
+ noextract = addon-49357-latest.xpi
+ source = https://addons.mozilla.org/firefox/downloads/latest/49357/platform:2/addon-49357-latest.xpi
+ sha256sums = 57ab91bdd4ae1dc231551ce3e164f6a8315bb3e36d3704423e7d64625ad1fbc4
pkgname = firefox-extension-kwallet
diff --git a/PKGBUILD b/PKGBUILD
index ac9fbc37aa71..139b13ca99d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,35 @@
# Maintainer: FadeMind <fademind@gmail.com>
-# Contributor: Bjoern Bidar <theodorstormgrade@gmail.com>
+# Contributor: Alois Nespor <info@aloisnespor.info>
+# Contributor: Tianjiao Yin <ytj000+aur@gmail.com>
-_plugin_name=kde_wallet_password_integration
+_dver=49357
pkgname=firefox-extension-kwallet
pkgver=2.4.1
pkgrel=2
pkgdesc="An extension to allows Firefox to use KDE's Kwallet to store passwords"
-arch=('i686' 'x86_64')
-url="https://addons.mozilla.org/firefox/addon/kde-wallet-password-integratio/"
-license=('MPL 1.1' 'GPL 2.0' 'LGPL 2.1')
-depends=('qt4' 'firefox' 'kwalletmanager')
+url="https://addons.mozilla.org/firefox/addon/kwallet/"
+depends=("firefox")
makedepends=('unzip')
-source=("${_plugin_name}-2.4-fx+tb-linux.xpi::https://addons.cdn.mozilla.net/user-media/addons/49357/${_plugin_name}-2.4-fx+tb-linux.xpi")
-sha256sums=('b424fa047c608763773dbc9ee77e960df35c8200ac3b7dfa335b476dc5d13fd3')
-noextract=("${_plugin_name}-2.4-fx+tb-linux.xpi")
+license=('MPL2')
+arch=('any')
+source=("https://addons.mozilla.org/firefox/downloads/latest/${_dver}/platform:2/addon-${_dver}-latest.xpi")
+sha256sums=('57ab91bdd4ae1dc231551ce3e164f6a8315bb3e36d3704423e7d64625ad1fbc4')
+noextract=(addon-${_dver}-latest.xpi)
+
+pkgver() {
+ sed -n '/.*<em:version>\(.*\)<\/em:version>.*/{s//\1/p;q}' install.rdf | cut -f 1 -d-
+}
prepare(){
- unzip -qqo ${_plugin_name}-2.4-fx+tb-linux.xpi
+ unzip -qqo addon-${_dver}-latest.xpi
}
package() {
- emid=$(grep -Pom1 'id>\K[^<]*' install.rdf)
- dstdir=$pkgdir/usr/lib/firefox/browser/extensions/$emid
- sed -i "s|<em:maxVersion>.*</em:maxVersion>|<em:maxVersion>99.*</em:maxVersion>|" install.rdf
- install -dm755 "$dstdir"
+ cd "$srcdir"
+ emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)
+ local dstdir="$pkgdir/usr/lib/firefox/browser/extensions/${emid}"
+ install -d "$dstdir"
rm *.xpi
- cp -r * "$dstdir/"
+ cp -dpr --no-preserve=ownership * "$dstdir"
+ chmod -R 755 "$dstdir"
}