summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Bourgeois2017-02-12 00:12:59 +0100
committerQuentin Bourgeois2017-02-12 00:12:59 +0100
commit0979a7fdde6a3b5c8a3aab2a2c248f39cdd725ee (patch)
tree8a85f9916eee32bec7d5cf9a153b741a387d6121
downloadaur-0979a7fdde6a3b5c8a3aab2a2c248f39cdd725ee.tar.gz
addpkg: firefox-extension-mooltipass 1.1.59-1
firefox-extension-mooltipass 1.1.59-1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD25
4 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac54b136d110
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = firefox-extension-mooltipass
+ pkgdesc = Retrieve and store Mooltipass credentials easily from websites.
+ pkgver = 1.1.59
+ pkgrel = 1
+ url = https://www.themooltipass.com/setup
+ arch = any
+ license = custom:MIT
+ depends = firefox
+ depends = moolticute
+ noextract = firefox-extension-mooltipass-1.1.59.xpi
+ source = firefox-extension-mooltipass-1.1.59.xpi::https://addons.mozilla.org/firefox/downloads/latest/mooltipass-extension/platform:2/addon-748426-latest.xpi
+ source = LICENSE
+ sha256sums = b3aecf1919c5ba7848570d82a25148e7c45dbbeabda149768d77c98e8329d844
+ sha256sums = 2af680c39ef493fb82830356d1d3df1acb5a06033cba2dec7a19e21caa77a866
+
+pkgname = firefox-extension-mooltipass
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..83f84b1baeeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+firefox-extension-mooltipass-*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..31ecdfb1dbc5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+
+ The above copyright notice and this permission notice shall be included in all
+ copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf2ff63f1df2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Quentin Bourgeois <quentin+archlinux@bourgeois.eu>
+
+_extension_name='mooltipass'
+_extension_id='{da36041e-5ce1-4c8a-9dc5-406cc98f0a23}'
+pkgname="firefox-extension-${_extension_name}"
+pkgver=1.1.59
+pkgrel=1
+pkgdesc='Retrieve and store Mooltipass credentials easily from websites.'
+license=('custom:MIT')
+arch=('any')
+url='https://www.themooltipass.com/setup'
+depends=('firefox'
+ 'moolticute')
+source=("${pkgname}-${pkgver}.xpi::https://addons.mozilla.org/firefox/downloads/latest/mooltipass-extension/platform:2/addon-748426-latest.xpi"
+ 'LICENSE')
+sha256sums=('b3aecf1919c5ba7848570d82a25148e7c45dbbeabda149768d77c98e8329d844'
+ '2af680c39ef493fb82830356d1d3df1acb5a06033cba2dec7a19e21caa77a866')
+noextract=("${pkgname}-${pkgver}.xpi")
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm 644 "${pkgname}-${pkgver}.xpi" "${pkgdir}/usr/lib/firefox/browser/extensions/${_extension_id}.xpi"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}