summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcameel2021-11-14 17:08:52 +0100
committercameel2021-11-14 17:08:52 +0100
commit5d801488f25234901c9e585f9926cd1f0901a5bd (patch)
tree01bd680e51803f81c7791cf12b6fee627ea600e1
parentce0313442b5e330c840d65fe800f24c89df02208 (diff)
downloadaur-5d801488f25234901c9e585f9926cd1f0901a5bd.tar.gz
Update to version 8.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43c340154786..de4bc1163212 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = firefox-extension-multi-account-containers
pkgdesc = Keep parts of your online life separated into color-coded tabs
- pkgver = 7.4.0
+ pkgver = 8.0.0
pkgrel = 1
url = https://github.com/mozilla/multi-account-containers
arch = any
@@ -9,7 +9,9 @@ pkgbase = firefox-extension-multi-account-containers
makedepends = npm
makedepends = unzip
makedepends = zip
- source = https://github.com/mozilla/multi-account-containers/archive/7.4.0/multi-account-containers-7.4.0.tar.gz
- sha512sums = a457c20132780e43ecbcecd3925e75df0ee441c02c3b2c0bdb18d0bf3a98918961bd5c81b439c841fd2616e385536cae757412e41dadc32e0738d56d8415f809
+ source = https://github.com/mozilla/multi-account-containers/archive/8.0.0/multi-account-containers-8.0.0.tar.gz
+ source = https://github.com/mozilla-l10n/multi-account-containers-l10n/archive/f3da295d004b7d6314c5baa321d9a5418ec937d9.tar.gz
+ sha512sums = ebe5ae9a3bdb4de1862d3263795df775c097f2e68d03e0dec4c9c77e225f31c3f1bcb58d3729c19c7fbf6a23996e82b3d7683592129079cf249042ff5b49a336
+ sha512sums = ae8d21be84b29337ba3b1377368a33e290323e7a445a305adc10beae2317775b539837e0272014c5f3f28348ddd9a6bbfff04aa60e5d64b826878ae44e8cd8ce
pkgname = firefox-extension-multi-account-containers
diff --git a/PKGBUILD b/PKGBUILD
index a89c33cb3ae8..ebfbe69ba126 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Maintainer: Plaunarome <plaunarome@protonmail.com>
_name="multi-account-containers"
+_l10n_version=f3da295d004b7d6314c5baa321d9a5418ec937d9
pkgname=firefox-extension-multi-account-containers
-pkgver=7.4.0
+pkgver=8.0.0
pkgrel=1
pkgdesc="Keep parts of your online life separated into color-coded tabs"
arch=("any")
@@ -11,14 +12,24 @@ url="https://github.com/mozilla/${_name}"
license=("MPL2")
groups=("firefox-addons")
makedepends=("npm" "unzip" "zip")
-source=("${url}/archive/${pkgver}/${_name}-${pkgver}.tar.gz")
-sha512sums=('a457c20132780e43ecbcecd3925e75df0ee441c02c3b2c0bdb18d0bf3a98918961bd5c81b439c841fd2616e385536cae757412e41dadc32e0738d56d8415f809')
+source=(
+ "${url}/archive/${pkgver}/${_name}-${pkgver}.tar.gz"
+ "https://github.com/mozilla-l10n/${_name}-l10n/archive/${_l10n_version}.tar.gz"
+)
+sha512sums=(
+ 'ebe5ae9a3bdb4de1862d3263795df775c097f2e68d03e0dec4c9c77e225f31c3f1bcb58d3729c19c7fbf6a23996e82b3d7683592129079cf249042ff5b49a336'
+ 'ae8d21be84b29337ba3b1377368a33e290323e7a445a305adc10beae2317775b539837e0272014c5f3f28348ddd9a6bbfff04aa60e5d64b826878ae44e8cd8ce'
+)
build() {
cd "${_name}-${pkgver}"
npm install --legacy-peer-deps
cd src
+ # Locale files are in a submodule. We do not have git info here so we have to insert it manually.
+ rm -rf _locales
+ ln -s "../../${_name}-l10n-${_l10n_version}" "_locales"
+
rm --force --recursive web-ext-artifacts
../node_modules/web-ext/bin/web-ext build --filename extension.zip --overwrite-dest
@@ -33,7 +44,7 @@ build() {
check() {
cd "${_name}-${pkgver}"
rm --force --recursive src/web-ext-artifacts
- npm test
+ npm run test:once
}
package() {