summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmeGa2015-07-07 03:01:41 -0500
committerOmeGa2015-07-07 03:01:41 -0500
commit6b9a72e939f8e658bd030cab83c60d5a21cca928 (patch)
tree038ff5bda55c82325ed5ed63b19a37ba30c3ae16
downloadaur-6b9a72e939f8e658bd030cab83c60d5a21cca928.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..644730cf9b8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = firefox-extension-omnibar
+ pkgdesc = Integrates the location bar and the search bar into one.
+ pkgver = 0.7.28.20141004
+ pkgrel = 1
+ url = https://addons.mozilla.org/en-US/firefox/addon/8823
+ arch = any
+ license = MPL
+ depends = firefox
+ source = https://addons.mozilla.org/firefox/downloads/file/278824/omnibar-0.7.28.20141004.xpi
+ sha1sums = 7fb603a37762c6af3c38c321f0c96baaca9fe69c
+
+pkgname = firefox-extension-omnibar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5138d3e0fb2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: OmeGa <omega [U+0040] mailoo [.] org>
+
+pkgname=firefox-extension-omnibar
+_file=278824
+pkgver=0.7.28.20141004
+pkgrel=1
+pkgdesc="Integrates the location bar and the search bar into one."
+arch=('any')
+url="https://addons.mozilla.org/en-US/firefox/addon/8823"
+license=('MPL')
+depends=('firefox')
+source=(https://addons.mozilla.org/firefox/downloads/file/$_file/omnibar-$pkgver.xpi)
+sha1sums=('7fb603a37762c6af3c38c321f0c96baaca9fe69c')
+
+package() {
+ cd "$srcdir"
+ local emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)
+ local dstdir="$pkgdir/usr/lib/firefox/browser/extensions/$emid"
+ find . -type f -exec install -Dm644 '{}' "$dstdir/{}" \;
+}
+
+# vim:set ts=2 sw=2 et: