summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:29:55 +0100
committerXZS2016-10-31 18:29:55 +0100
commite8b7e2e62acce5ef3ea4945e19383215362ea85d (patch)
tree3b2c32f5896163b9deae75a4058e5f79f1a7b208
parentb648de7904c823483fcb7c744cd2a5b6e19e5103 (diff)
downloadaur-e8b7e2e62acce5ef3ea4945e19383215362ea85d.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe068ac6f03d..076271bdc8e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-extension-omnisidebar
pkgdesc = A firefox add-on designed to provide more control over the behavior of the sidebar.
pkgver = 1.6.13
- pkgrel = 1
+ pkgrel = 2
url = https://addons.mozilla.org/firefox/addon/omnisidebar/
arch = any
license = MPLv2
diff --git a/PKGBUILD b/PKGBUILD
index 0e1e8f8b5a15..1afed14d5813 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-extension-omnisidebar
pkgver=1.6.13
-pkgrel=1
+pkgrel=2
pkgdesc='A firefox add-on designed to provide more control over the behavior of the sidebar.'
arch=('any')
license=('MPLv2')
@@ -43,9 +43,18 @@ query-version() {
xmllint .version --xpath \
"//application[appID='$2']/$1_version/text()"
}
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {