summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-20 18:41:24 +0200
committerXZS2016-04-20 18:41:24 +0200
commit33422a4e52ff2624a10a8699b6f5495d8b95e9d5 (patch)
tree2a861123cd8cad0112a31852974220e2c66ad2bd
parent18980a99e20b7f50606c19ea08cbc86ae2d266b0 (diff)
downloadaur-33422a4e52ff2624a10a8699b6f5495d8b95e9d5.tar.gz
omit hidden files
Hidden files are normally only used to manage the source code of the extension. They are not needed in and have no direct relation to the compiled package and can thus be left out safely. At this moment, there are no hidden files in this extension. So this change happens just in anticipation to future additions and not raising the need to increment the pkgrel.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7568226c737..637db6e5c09d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -79,7 +79,8 @@ depends=(${pkgname%%-*})
package() {
compose_dependencies
prepare_target
- cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ install -d "$destdir/$id"
+ cp --no-preserve=ownership,mode -r * "$destdir/$id"
}
# Hidden from mksrcinfo in silly subfunction.