summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-10-31 18:39:02 +0100
committerXZS2016-10-31 18:39:02 +0100
commite5c65b8136cf8167c8b3c77f325a9cdda7152be0 (patch)
tree15a7df8d115043ba0ef8bc7ded2740a134eac97f
parent7c34b6a26c0479370eebfb4af0162c4d766f8af5 (diff)
downloadaur-e5c65b8136cf8167c8b3c77f325a9cdda7152be0.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f808bb5bb5e..8abe62d42d5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-extension-omnisidebar-git
pkgdesc = A firefox add-on designed to provide more control over the behavior of the sidebar.
pkgver = 1.6.13
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Quicksaver/OmniSidebar
arch = any
license = MPLv2
diff --git a/PKGBUILD b/PKGBUILD
index 17a9b2dff2d4..e0cb027fba1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-extension-omnisidebar-git
pkgver=1.6.13
-pkgrel=1
+pkgrel=2
pkgdesc='A firefox add-on designed to provide more control over the behavior of the sidebar.'
url='https://github.com/Quicksaver/OmniSidebar'
arch=('any')
@@ -44,9 +44,18 @@ pkgver() {
echo -n .
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {