summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsprocklem2019-01-14 19:19:25 -0700
committersprocklem2019-01-14 19:19:25 -0700
commit7c2d4bb013f85a11f3c020b2b57b0efc39f6c905 (patch)
treeb112f4de1ceb1c81d7693f247f41264be9759a2d
parent0104d3501500a24ddc80ed8d0f595f290be59bf8 (diff)
downloadaur-7c2d4bb013f85a11f3c020b2b57b0efc39f6c905.tar.gz
Small tweaks to PKGBUILD.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15e69f1b28cd..611660684c8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-extension-overbitenx
pkgdesc = Add gopher support to Firefox (beta)
pkgver = 0.9.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/classilla/overbitenx
arch = x86_64
groups = firefox-addons
diff --git a/PKGBUILD b/PKGBUILD
index 6261fef91d0a..ccbcffcbf754 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname="overbitenx"
pkgname="firefox-extension-${_pkgname}"
pkgver='0.9.2.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc="Add gopher support to Firefox (beta)"
arch=('x86_64')
url="https://github.com/classilla/overbitenx"
@@ -16,19 +16,20 @@ sha256sums=('bf3fa2cf5baaf8503d4ce15bae21071d10f3bd265937e1660765ae0e6f21f56c'
prepare() {
cd "${_pkgname}-${pkgver}"
- sed 's|/home/linus/bin/onyx|/usr/lib/overbitenx/onyx|g' EXAMPLE_onyx.json >onyx.json
+ sed "s|/home/linus/bin/onyx|/usr/lib/${_pkgname}/onyx|g" EXAMPLE_onyx.json >onyx.json
}
build() {
cd "${_pkgname}-${pkgver}"
- # Since the onyx build rule is defined in Makefile.default, this should use the (superior) implicit build rule and not redefine CC for some reason.
+ # Since the onyx build rule is defined in Makefile.default, this should use the (superior)
+ # implicit build rule and not redefine CC for some reason.
make onyx
}
package() {
install -Dm644 "${_pkgname}-${pkgver}.xpi" "${pkgdir}/usr/lib/firefox/browser/extensions/overbitenx@floodgap.com.xpi"
install -Dm644 "${_pkgname}-${pkgver}/onyx.json" "${pkgdir}/usr/lib/mozilla/native-messaging-hosts/onyx.json"
- install -Dm755 "${_pkgname}-${pkgver}/onyx" "${pkgdir}/usr/lib/overbitenx/onyx"
+ install -Dm755 "${_pkgname}-${pkgver}/onyx" "${pkgdir}/usr/lib/${_pkgname}/onyx"
install -Dm644 "${_pkgname}-${pkgver}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}