summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCookie Engineer2018-08-20 18:29:48 +0200
committerCookie Engineer2018-08-20 18:29:48 +0200
commit1a68a6b3c476f13feb40fb4b352c93a281acbc61 (patch)
treea7233133017d9b6cf4a08ce7699777e37c958079
downloadaur-1a68a6b3c476f13feb40fb4b352c93a281acbc61.tar.gz
1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1eb1b1928f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = firefox-extension-privacy-pass
+ pkgdesc = Handle passes containing cryptographically blinded tokens for bypassing challenge pages.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/privacypass/challenge-bypass-extension
+ arch = any
+ license = BSD
+ depends = firefox
+ noextract = cloudflare_privacy_pass-1.0-an+fx.xpi
+ source = https://addons.mozilla.org/firefox/downloads/file/758380/cloudflare_privacy_pass-1.0-an+fx.xpi
+ sha256sums = f5791179a4a1d4435431de3627df88a0e544444ccf3d434bd3d645bf87141ff2
+
+pkgname = firefox-extension-privacy-pass
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0e8e9da7789
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Cookie Engineer <cookiengineer@protonmail.ch>
+
+pkgname=firefox-extension-privacy-pass
+pkgver=1.0
+pkgrel=1
+pkgdesc='Handle passes containing cryptographically blinded tokens for bypassing challenge pages.'
+url=https://github.com/privacypass/challenge-bypass-extension
+arch=('any')
+license=('BSD')
+depends=('firefox')
+source=("https://addons.mozilla.org/firefox/downloads/file/758380/cloudflare_privacy_pass-$pkgver-an+fx.xpi")
+noextract=("${source##*/}")
+sha256sums=('f5791179a4a1d4435431de3627df88a0e544444ccf3d434bd3d645bf87141ff2')
+
+package() {
+ install -Dm755 "${source##*/}" "$pkgdir"/usr/lib/firefox/browser/extensions/privacy-pass.xpi
+}
+
+# vim:set ts=2 sw=2 et: