summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-12-23 11:59:03 +0330
committerMohammadreza Abdollahzadeh2022-12-23 11:59:03 +0330
commit55b14b6e50bc6115dfac94889299d0c4078dffe6 (patch)
treed6d82f0d955c8d55087beca8c7e22bf02cb8cf48
parentf9c8e11f1fe7a571924490cf2fb49b7aaf62bfd1 (diff)
downloadaur-55b14b6e50bc6115dfac94889299d0c4078dffe6.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9629013b52cb..db382d0bd38f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = firefox-extension-privacy-pass
- pkgdesc = Handle passes containing cryptographically blinded tokens for bypassing challenge pages.
- pkgver = 2.0.6
+ pkgdesc = Firefox extension implements the client-side of the Privacy Pass protocol providing unlinkable cryptographic tokens.
+ pkgver = 3.0.4
pkgrel = 1
- url = https://github.com/privacypass/challenge-bypass-extension
+ url = https://addons.mozilla.org/en-US/firefox/addon/privacy-pass/
arch = any
- license = BSD
+ groups = firefox-addons
+ license = BSD-3
depends = firefox
- noextract = privacy_pass-2.0.6-fx.xpi
- source = https://addons.mozilla.org/firefox/downloads/file/3556492/privacy_pass-2.0.6-fx.xpi
- sha512sums = 6cab6d4951febd0629231416d1553f14eb8ed6141450f0cb1461dd408945d7a4c242856eabb48bf3fad7d896e759b17ae3db879d1d4a151c0e66a90aec89d8f7
+ source = firefox-extension-privacy-pass-3.0.4.xpi::https://addons.mozilla.org/firefox/downloads/file/4029152/privacy_pass-3.0.4.xpi
+ sha256sums = acb6d3001e2af078792bdde7154113dacb9434eb0d55d81e96923b11a0594a9b
pkgname = firefox-extension-privacy-pass
-
diff --git a/PKGBUILD b/PKGBUILD
index 603cbb9257de..3852f938d893 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
-# Maintainer: Cookie Engineer <@cookiengineer>
-
+# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
pkgname=firefox-extension-privacy-pass
-pkgver=2.0.6
+pkgver=3.0.4
pkgrel=1
-pkgdesc='Handle passes containing cryptographically blinded tokens for bypassing challenge pages.'
-url=https://github.com/privacypass/challenge-bypass-extension
+pkgdesc='Firefox extension implements the client-side of the Privacy Pass protocol providing unlinkable cryptographic tokens.'
arch=('any')
-license=('BSD')
+url='https://addons.mozilla.org/en-US/firefox/addon/privacy-pass/'
+license=('BSD-3')
depends=('firefox')
-source=("https://addons.mozilla.org/firefox/downloads/file/3556492/privacy_pass-$pkgver-fx.xpi")
-noextract=("${source##*/}")
-sha512sums=('6cab6d4951febd0629231416d1553f14eb8ed6141450f0cb1461dd408945d7a4c242856eabb48bf3fad7d896e759b17ae3db879d1d4a151c0e66a90aec89d8f7')
+groups=('firefox-addons')
+source=("${pkgname}-${pkgver}.xpi::https://addons.mozilla.org/firefox/downloads/file/4029152/privacy_pass-${pkgver}.xpi")
+sha256sums=('acb6d3001e2af078792bdde7154113dacb9434eb0d55d81e96923b11a0594a9b')
package() {
- install -Dm755 "${source##*/}" "$pkgdir"/usr/lib/firefox/browser/extensions/privacy-pass.xpi
+ install -Dm644 ${pkgname}-${pkgver}.xpi "${pkgdir}/usr/lib/firefox/browser/extensions/{48748554-4c01-49e8-94af-79662bf34d50}.xpi"
}
-
-# vim:set ts=2 sw=2 et:
+# vim:set ts=4 sw=4 et: