summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2015-06-08 12:22:56 +0200
committerFadeMind2015-06-08 12:22:56 +0200
commit173d178f6280a2effe8e9cc87cc07e5308a096b9 (patch)
tree1c29f8aba6507c5b7b299368606690f85db06f75
downloadaur-173d178f6280a2effe8e9cc87cc07e5308a096b9.tar.gz
2.9-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f91968a90ab0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = firefox-extension-saved-password-editor
+ pkgdesc = Adds the ability to create and edit entries in the password manager.
+ pkgver = 2.9
+ pkgrel = 1
+ url = https://addons.mozilla.org/firefox/addon/saved-password-editor/
+ arch = any
+ license = GPLv3
+ depends = firefox
+ source = https://addons.cdn.mozilla.net/user-media/addons/60265/saved_password_editor-2.9-sm+tb+fx.xpi
+ sha256sums = 40d0e4fae8c511dfd08b51102ed384fca0ea5b05ca8f0192b01d30d5122e49b0
+
+pkgname = firefox-extension-saved-password-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..162d4b4469b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+# Contributor: Tianjiao Yin <ytj000+aur@gmail.com>
+
+_plugin_name=saved_password_editor
+pkgname=firefox-extension-saved-password-editor
+pkgver=2.9
+pkgrel=1
+pkgdesc="Adds the ability to create and edit entries in the password manager."
+url="https://addons.mozilla.org/firefox/addon/saved-password-editor/"
+depends=("firefox")
+license=('GPLv3')
+arch=('any')
+source=("https://addons.cdn.mozilla.net/user-media/addons/60265/${_plugin_name}-${pkgver}-sm+tb+fx.xpi")
+
+package() {
+ install -D ${srcdir}/*.xpi ${pkgdir}/usr/lib/firefox/browser/extensions/savedpasswordeditor@daniel.dawson.xpi
+}
+
+sha256sums=('40d0e4fae8c511dfd08b51102ed384fca0ea5b05ca8f0192b01d30d5122e49b0')