summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2023-01-07 20:58:45 +0330
committerMohammadreza Abdollahzadeh2023-01-07 20:58:45 +0330
commitf649abead3aa739751c6b351bbd7e74d13830cad (patch)
tree078d10d5ea6a595c84e586a1cc80739c9f84cdfd
downloadaur-f649abead3aa739751c6b351bbd7e74d13830cad.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6009e2af8c65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = firefox-extension-uget-integration
+ pkgdesc = uGet Download Manager integration extension for Firefox.
+ pkgver = 2.1.3
+ pkgrel = 1
+ url = https://addons.mozilla.org/en-US/firefox/addon/ugetintegration/
+ arch = any
+ groups = firefox-addons
+ license = GPL3
+ depends = firefox
+ noextract = firefox-extension-uget-integration-2.1.3.zip
+ source = firefox-extension-uget-integration-2.1.3.zip::https://github.com/ugetdm/uget-extension/releases/download/v2.1.3/uget-integration-firefox.zip
+ sha512sums = 77a1983445cc9ed055cd0483d92f1041b0fd5a32c03579143ddc290472e6d6c9454475a1c091df12bd09a472f683de2751ccc64dff17615da6237eac4edfb32f
+
+pkgname = firefox-extension-uget-integration
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79e857f3c169
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
+pkgname=firefox-extension-uget-integration
+pkgver=2.1.3
+pkgrel=1
+pkgdesc='uGet Download Manager integration extension for Firefox.'
+arch=('any')
+url='https://addons.mozilla.org/en-US/firefox/addon/ugetintegration/'
+_gh_url='https://github.com/ugetdm/uget-extension'
+license=('GPL3')
+depends=('firefox')
+groups=('firefox-addons')
+source=("${pkgname}-${pkgver}.zip::${_gh_url}/releases/download/v${pkgver}/uget-integration-firefox.zip")
+noextract=("${pkgname}-${pkgver}.zip")
+sha512sums=('77a1983445cc9ed055cd0483d92f1041b0fd5a32c03579143ddc290472e6d6c9454475a1c091df12bd09a472f683de2751ccc64dff17615da6237eac4edfb32f')
+
+package() {
+ cd ${srcdir}
+ install -D -m 644 "${pkgname}-${pkgver}.zip" "${pkgdir}/usr/lib/firefox/browser/extensions/uget-integration@slgobinath.xpi"
+}
+# vim:set ts=4 sw=4 et:
+