summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2016-04-07 19:19:38 +0200
committerFadeMind2016-04-07 19:19:38 +0200
commit1ae336a0ded5b13d76775ff8ffa84ac213bbd0bb (patch)
tree1f85e57861b13f9e7edad5f188d7d4910feb676e
parent1746fa81d09dd196cc6d530361481017cbd6952d (diff)
downloadaur-1ae336a0ded5b13d76775ff8ffa84ac213bbd0bb.tar.gz
update
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
3 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a3a42b181f6..3bd5cf5db063 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
+# Generated by mksrcinfo v8
+# Thu Apr 7 17:19:38 UTC 2016
pkgbase = firefox-extension-unmht
- pkgdesc = view MHT (MHTML) web archive format files, and save complete web pages, including text and graphics, into a single MHT file.
- pkgver = 7.3.0.5
+ pkgdesc = view MHT (MHTML) web archive format files, and save complete web pages, including text and graphics, into a single MHT file
+ pkgver = 8.1.0
pkgrel = 1
url = https://addons.mozilla.org/firefox/addon/unmht
arch = any
license = MPL
depends = firefox
- source = unmht-7.3.0.5.xpi::https://addons.cdn.mozilla.net/user-media/addons/8051/unmht-7.3.0.5-sm+an+fx+tb.xpi
- sha256sums = 1ef360d4aa7f5991a49c642d9d132de6dab5807729a9207a133602454ab445aa
+ source = unmht-8.1.0.xpi::https://addons.cdn.mozilla.net/user-media/addons/8051/unmht-8.1.0-sm+tb+fx+an.xpi
+ sha256sums = f47f77e04e9938560c50e4684557ebe4c9355b6cacea430ce91d8d16f88e85b3
pkgname = firefox-extension-unmht
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..81be5d92e399
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.SRCINFO
+!.gitignore
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
index 4955bf5a759d..29c127299a83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,23 @@
# Contributor: Tianjiao Yin <ytj000+aur@gmail.com>
_plugin_name=unmht
-_plugin_version=7.3.0.5
-pkgdesc="view MHT (MHTML) web archive format files, and save complete web pages, including text and graphics, into a single MHT file."
-license=('MPL')
-
pkgname=firefox-extension-${_plugin_name}
-pkgver=${_plugin_version}
+pkgver=8.1.0
pkgrel=1
+pkgdesc="view MHT (MHTML) web archive format files, and save complete web pages, including text and graphics, into a single MHT file"
+license=('MPL')
arch=('any')
-url="https://addons.mozilla.org/firefox/addon/unmht"
+url="https://addons.mozilla.org/firefox/addon/${_plugin_name}"
depends=("firefox")
-source=("${_plugin_name}-${_plugin_version}.xpi::https://addons.cdn.mozilla.net/user-media/addons/8051/${_plugin_name}-${_plugin_version}-sm+an+fx+tb.xpi")
+source=("${_plugin_name}-${pkgver}.xpi::https://addons.cdn.mozilla.net/user-media/addons/8051/${_plugin_name}-${pkgver}-sm+tb+fx+an.xpi")
+sha256sums=('f47f77e04e9938560c50e4684557ebe4c9355b6cacea430ce91d8d16f88e85b3')
package() {
- cd $srcdir
- emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
- local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
- install -d $dstdir
- rm *.xpi
- mv * $dstdir
+ cd $srcdir
+ emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+ local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
+ install -d $dstdir
+ rm *.xpi
+ mv * $dstdir
}
-sha256sums=('1ef360d4aa7f5991a49c642d9d132de6dab5807729a9207a133602454ab445aa')
+