summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2016-05-28 18:42:47 +0200
committerFadeMind2016-05-28 18:42:47 +0200
commit218e4a6b7f1d96f67838892fab3a259ba631f7de (patch)
tree6116b8c1e00f5087bff11dfadda825f53a8f44e8
parent55037f6405f916e065fff992fc3d294ce56135a3 (diff)
downloadaur-218e4a6b7f1d96f67838892fab3a259ba631f7de.tar.gz
valid install way against firefox sign
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dab0afea2c76..a67dae4518e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Mon Apr 11 10:20:10 UTC 2016
+# Sat May 28 16:42:07 UTC 2016
pkgbase = firefox-extension-unmht
pkgdesc = view MHT (MHTML) web archive format files, and save complete web pages, including text and graphics, into a single MHT file
pkgver = 8.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://addons.mozilla.org/firefox/addon/unmht
arch = any
license = MPL
makedepends = unzip
depends = firefox
- noextract = unmht-8.1.0.xpi
- source = unmht-8.1.0.xpi::https://addons.cdn.mozilla.net/user-media/addons/8051/unmht-8.1.0-sm+tb+fx+an.xpi
+ noextract = unmht-8.1.0-sm+tb+fx+an.xpi
+ source = https://addons.cdn.mozilla.net/user-media/addons/8051/unmht-8.1.0-sm+tb+fx+an.xpi
sha256sums = f47f77e04e9938560c50e4684557ebe4c9355b6cacea430ce91d8d16f88e85b3
pkgname = firefox-extension-unmht
diff --git a/PKGBUILD b/PKGBUILD
index 824adc7c76e6..10071b31181c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,27 @@
_plugin_name=unmht
pkgname=firefox-extension-${_plugin_name}
pkgver=8.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="view MHT (MHTML) web archive format files, and save complete web pages, including text and graphics, into a single MHT file"
license=('MPL')
arch=('any')
url="https://addons.mozilla.org/firefox/addon/${_plugin_name}"
depends=("firefox")
makedepends=('unzip')
-source=("${_plugin_name}-${pkgver}.xpi::https://addons.cdn.mozilla.net/user-media/addons/8051/${_plugin_name}-${pkgver}-sm+tb+fx+an.xpi")
+source=("https://addons.cdn.mozilla.net/user-media/addons/8051/${_plugin_name}-${pkgver}-sm+tb+fx+an.xpi")
sha256sums=('f47f77e04e9938560c50e4684557ebe4c9355b6cacea430ce91d8d16f88e85b3')
-noextract=("${_plugin_name}-${pkgver}.xpi")
+noextract=("${_plugin_name}-${pkgver}-sm+tb+fx+an.xpi")
prepare(){
- unzip -qqo ${_plugin_name}-${pkgver}.xpi
+ unzip -qqo ${_plugin_name}-${pkgver}-sm+tb+fx+an.xpi
}
package() {
- cd $srcdir
- emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
- local dstdir=$pkgdir/usr/lib/firefox/browser/extensions/${emid}
- install -d $dstdir
+ cd "$srcdir"
+ emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)
+ local dstdir="$pkgdir/usr/lib/firefox/browser/extensions/${emid}"
+ install -d "$dstdir"
rm *.xpi
- mv * $dstdir
+ cp -dpr --no-preserve=ownership * "$dstdir"
+ chmod -R 755 "$dstdir"
}
-