summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2019-02-15 19:27:43 +0100
committerJulien Nicoulaud2019-02-15 19:27:43 +0100
commit51c237610a3556316f30e64d9e8a844e8ede09db (patch)
treeecff3c68b6bf96efa9f1d72ce7cb0258294caeac
downloadaur-51c237610a3556316f30e64d9e8a844e8ede09db.tar.gz
7.3.5
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD18
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..152ee6fc409c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = firefox-extension-video-download-helper
+ pkgdesc = The easy way to download and convert Web videos from hundreds of YouTube-like sites.
+ pkgver = 7.3.5
+ pkgrel = 1
+ url = https://addons.mozilla.org/en-US/firefox/addon/video-downloadhelper
+ arch = any
+ license = custom:proprietary
+ depends = firefox
+ optdepends = firefox-extension-video-download-helper-companion-app: companion app, compiled from sources (see https://www.downloadhelper.net/install-coapp)
+ optdepends = firefox-extension-video-download-helper-companion-app-bin: companion app, using binary artifacts (see https://www.downloadhelper.net/install-coapp)
+ noextract = extension.xpi
+ source = extension.xpi::https://addons.mozilla.org/firefox/downloads/file/1031851/video_downloadhelper-7.3.5-an+fx.xpi
+ sha256sums = d7031e6f5db343fcd625d50e93fafe4f0d017ae7a0a88316893fc85bb0930dec
+
+pkgname = firefox-extension-video-download-helper
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1ef1d32036d7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/pkg/
+/src/
+/*.tar.gz
+/*.xz
+/*.zst
+/*.swp
+/*.xpi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c9a39d73b5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=firefox-extension-video-download-helper
+_file=1031851
+pkgver=7.3.5
+pkgrel=1
+pkgdesc='The easy way to download and convert Web videos from hundreds of YouTube-like sites.'
+arch=('any')
+url='https://addons.mozilla.org/en-US/firefox/addon/video-downloadhelper'
+license=('custom:proprietary')
+depends=('firefox')
+optdepends=('firefox-extension-video-download-helper-companion-app: companion app, compiled from sources (see https://www.downloadhelper.net/install-coapp)'
+ 'firefox-extension-video-download-helper-companion-app-bin: companion app, using binary artifacts (see https://www.downloadhelper.net/install-coapp)')
+source=("extension.xpi::https://addons.mozilla.org/firefox/downloads/file/${_file}/video_downloadhelper-${pkgver}-an+fx.xpi")
+noextract=("extension.xpi")
+sha256sums=('d7031e6f5db343fcd625d50e93fafe4f0d017ae7a0a88316893fc85bb0930dec')
+
+package() {
+ install -Dm644 extension.xpi "${pkgdir}/usr/lib/firefox/browser/extensions/{b9db16a4-6edc-47ec-a1f4-b86292ed211d}.xpi"
+}