summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoerg Weislogel2023-09-20 09:06:44 +0200
committerJoerg Weislogel2023-09-20 09:06:44 +0200
commit96165127f4fc6e28be3153cc0d2c0f906324536e (patch)
tree9f432958054f52547bf91b03a20722d8b32b722a
parent813d18eee43747304345419e24c8f27ef53b2fa1 (diff)
downloadaur-96165127f4fc6e28be3153cc0d2c0f906324536e.tar.gz
added package version to source filename to avoid issues with unclean builds
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1802476e9e2a..0c1a12a91081 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = firefox-extension-video-download-helper
pkgdesc = The easy way to download and convert Web videos from hundreds of YouTube-like sites.
pkgver = 8.0.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://www.downloadhelper.net
arch = any
groups = firefox-addons
@@ -10,9 +10,9 @@ pkgbase = firefox-extension-video-download-helper
optdepends = vdhcoapp: companion app, see https://www.downloadhelper.net/install-coapp
optdepends = vdhcoapp-bin: companion app (binary version)
noextract = license.html
- noextract = extension.xpi
+ noextract = extension_8.0.0.6-2.xpi
source = license.html::https://www.downloadhelper.net/terms-of-service
- source = extension.xpi::https://addons.mozilla.org//firefox/downloads/file/4157053/video_downloadhelper-8.0.0.6.xpi
+ source = extension_8.0.0.6-2.xpi::https://addons.mozilla.org//firefox/downloads/file/4157053/video_downloadhelper-8.0.0.6.xpi
sha512sums = SKIP
sha512sums = 4b8f37bd4d28fce232fe4bf25ef874c99efca18ed7351a8a656a04490c63d590c3dbe81fc7bcdd739dd342d73d113f9d793ae4879e0b8c1697863d093621ba06
diff --git a/PKGBUILD b/PKGBUILD
index 5f8ed8343f21..37d418ee6cd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=firefox-extension-video-download-helper
pkgver=8.0.0.6
-pkgrel=1
+pkgrel=2
pkgdesc='The easy way to download and convert Web videos from hundreds of YouTube-like sites.'
arch=('any')
url='https://www.downloadhelper.net'
@@ -14,14 +14,14 @@ groups=('firefox-addons')
optdepends=('vdhcoapp: companion app, see https://www.downloadhelper.net/install-coapp'
'vdhcoapp-bin: companion app (binary version)')
source=("license.html::https://www.downloadhelper.net/terms-of-service"
- "extension.xpi::https://addons.mozilla.org//firefox/downloads/file/4157053/video_downloadhelper-${pkgver}.xpi")
+ "extension_${pkgver}-${pkgrel}.xpi::https://addons.mozilla.org//firefox/downloads/file/4157053/video_downloadhelper-${pkgver}.xpi")
noextract=("license.html"
- "extension.xpi")
+ "extension_${pkgver}-${pkgrel}.xpi")
sha512sums=(SKIP
'4b8f37bd4d28fce232fe4bf25ef874c99efca18ed7351a8a656a04490c63d590c3dbe81fc7bcdd739dd342d73d113f9d793ae4879e0b8c1697863d093621ba06')
package() {
- install -Dm644 extension.xpi "${pkgdir}/usr/lib/firefox/browser/extensions/{b9db16a4-6edc-47ec-a1f4-b86292ed211d}.xpi"
+ install -Dm644 extension_${pkgver}-${pkgrel}.xpi "${pkgdir}/usr/lib/firefox/browser/extensions/{b9db16a4-6edc-47ec-a1f4-b86292ed211d}.xpi"
install -Dm644 license.html "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.html"
}