summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmeGa2016-01-31 23:59:39 -0600
committerOmeGa2016-01-31 23:59:39 -0600
commit7b00b9939f85a8013fa0411ff113ac2564584d55 (patch)
tree086f29012c4c4bccd69c4b0862253dfa8e180866
parent1d9572cd17aa927900569fc6132a85d3f6531900 (diff)
downloadaur-7b00b9939f85a8013fa0411ff113ac2564584d55.tar.gz
update to 0.11.0
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ed3cb23871b..52812e035d0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: OmeGa <omega [U+0040] mailoo [.] org>
pkgname=firefox-extension-vimfx
-_file=374186
-pkgver=0.10.0
+_file=386421
+pkgver=0.11.0
pkgrel=1
pkgdesc="Introduces Vim-style keyboard shortcuts for browsing and navigation without using the mouse."
arch=('any')
@@ -11,16 +11,16 @@ license=('MIT')
depends=('firefox>=40.0')
source=(https://addons.mozilla.org/firefox/downloads/file/$_file/vimfx-$pkgver.xpi
LICENSE)
-sha1sums=('77e0dad27233f13f3c51bff3741bcd3cb9aee577'
+sha1sums=('336eec2a068fe40b03369b0a59a3b20010b3eee8'
'f1eaf939b37946dea611a5d55ef4784306c70a53')
package() {
- cd "$srcdir"
- local emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)
- local dstdir="$pkgdir/usr/lib/firefox/browser/extensions/$emid"
- find . -type f -exec install -Dm644 '{}' "$dstdir/{}" \;
-
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd $srcdir
+ local _emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+ test ! -z "${_emid}"
+ local _file=(*.xpi)
+ test "${#_file[@]}" -eq 1
+ install -Dpm644 "${_file}" "${pkgdir}/usr/lib/firefox/browser/extensions/${_emid}.xpi"
}
# vim:set ts=2 sw=2 et: