summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYork-Simon Johannsen2020-01-27 19:18:43 +0100
committerYork-Simon Johannsen2020-01-27 19:18:43 +0100
commitc66a1b64bf6e31bfa3f923964d81903c3f4d09cd (patch)
tree3ef68a2c1a2a993c2d0df672518dbeaacdcaaf82
downloadaur-c66a1b64bf6e31bfa3f923964d81903c3f4d09cd.tar.gz
3.5.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..014131867b0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = firefox-floccus
+ pkgdesc = Sync your bookmarks across browsers via Nextcloud, WebDAV or a local file (and thus any file sync solution) https://floccus.org
+ pkgver = 3.5.3
+ pkgrel = 1
+ url = https://github.com/marcelklehr/floccus
+ arch = any
+ groups = firefox-addons
+ license = MPL-2.0
+ noextract = floccus-3.5.3-fx.xpi
+ source = https://addons.mozilla.org/firefox/downloads/file/3469973/floccus-3.5.3-fx.xpi
+ sha256sums = bd14c256a8f4164a2a4c69a23c047940df8cb186abb6b6fd5237184a9c7455eb
+
+pkgname = firefox-floccus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eacbc8e990f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: York-Simon Johannsen <info@yosijo.de>
+
+pkgname=firefox-floccus
+pkgver=3.5.3
+pkgrel=1
+pkgdesc='Sync your bookmarks across browsers via Nextcloud, WebDAV or a local file (and thus any file sync solution) https://floccus.org'
+url=https://github.com/marcelklehr/floccus
+arch=('any')
+license=('MPL-2.0')
+groups=('firefox-addons')
+source=("https://addons.mozilla.org/firefox/downloads/file/3469973/floccus-$pkgver-fx.xpi")
+noextract=("${source##*/}")
+sha256sums=('bd14c256a8f4164a2a4c69a23c047940df8cb186abb6b6fd5237184a9c7455eb')
+
+package() {
+ install -Dm644 "${source##*/}" "$pkgdir"/usr/lib/firefox/browser/extensions/floccus@handmadeideas.org.xpi
+}
+
+# vim:set ts=2 sw=2 et: